Pourcentage dans recherchev [Résolu/Fermé]

Signaler
Messages postés
243
Date d'inscription
vendredi 14 février 2014
Statut
Membre
Dernière intervention
21 avril 2019
-
Messages postés
52041
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 août 2020
-
Bonjour à tous,

Voilà mon problème pourriez vous s'il vous plait me donner un petit coup de main
image jointe.
Je veux noter en C1 , la fonction recherchev qui devrait me renvoyer oui 60%
Donc respectivement en admettant que nous sommes le 03/02/19
recherchev(a1;c3:g33;4;0)&(a1;c3:g33;5;0) mais cela me renvoie oui0,6
première question : comment renvoyer le 0,6 en 60%
seconde question : j'aimerais avoir un espace après le oui.
Surement une histoire de formatage de cellule mais je n'arrive pas à trouver dans certains exemple.
Merci pour vos réponses toujours aussi pertinentes
Cordialement
Soubisien85

1 réponse

Messages postés
52041
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 août 2020
13 790
=RECHERCHEV(A1;C3:G33;4;0) & " " & TEXTE( RECHERCHEV(A1;C3:G33;5;0) ; "#%")

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56981 internautes nous ont dit merci ce mois-ci

Messages postés
52041
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 août 2020
13 790
Effectivement pour ta première question c'est un problème de formatage :
=TEXTE(0,6;"#%") affiche comme résultat 60%

Mais pour la seconde question c'est un problème de formule, car tu as oublié d'insérer une espace entre les deux valeurs recherchées :
="Bonjour" & "monsieur" ne peut afficher que "Bonjourmonsieur"
et il convient d'intercaler dans ta concaténation le caractère vide, ce qui donne
="Bonjour" & " " & "monsieur" qui affichera "Bonjour monsieur"
Messages postés
243
Date d'inscription
vendredi 14 février 2014
Statut
Membre
Dernière intervention
21 avril 2019
2
ou alors "Bonjour "&"Monsieur"
En tout cas pour la formule pourcentage
merci beaucoup
soubisien85
Messages postés
52041
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 août 2020
13 790
... et dans ton cas, il ne faudrait pas saisir "Oui" en A2, mais "Oui " !
et "Non " à la place de "Non" en A3 ...