Extraction de valeurs d'un tableau excel vers un autre

[Résolu/Fermé]
Signaler
Messages postés
17
Date d'inscription
mercredi 20 décembre 2017
Statut
Membre
Dernière intervention
10 janvier 2019
-
Messages postés
54858
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
-
Bonjour les amis, je travaille sur un projet consistant à extraire des infos precises d'un tableau d'une feuille vers une autre. La première contient en tete : Date/Opération/Montant/Travailleur 1/Travailleur 2/..../Travailleur 8/Gain Ind. Le principe est simple, ce tableau me permet de reporter chaque jour les opérations menées par ces travailleurs et de calculer leurs gains individuels. En fin de semaine, leurs noms, les dates du lundi au samedi ainsi que et les montants quotidiens dus est contenu dans le tableau 2 qui contient en tete: Nom/lundi/mardi..../samedi/Montant Total.
Il s'agit pour moi de trouver une formule permettant de repartir les montants quotidiens en fonction du travailleur et du jour concerné. J'essaie avec somme.si mais niet, il manque certaines combinaisons.

3 réponses

Messages postés
54858
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
16 766
Bonjour.

Prière d'envoyer un fichier-exemple.
On ne peut pas t'écrire une formule sans mettre des références de cellules et de feuilles ...
Messages postés
17
Date d'inscription
mercredi 20 décembre 2017
Statut
Membre
Dernière intervention
10 janvier 2019
2
Merci d'avance Mr Raymond: https://mon-partage.fr/f/PazfOjll/
Messages postés
54858
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
16 766
Ton document est protégé, et nous n'avons pas le mot de passe !
Messages postés
17
Date d'inscription
mercredi 20 décembre 2017
Statut
Membre
Dernière intervention
10 janvier 2019
2
oulala le mot de passe est : ldp2018
Messages postés
54858
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
16 766
Bien ... J'ai regardé ton fichier.

1) Les cellules fusionnées, comme d'habitude, empêchent tout calcul.
Tu dois donc commencer par répéter les dates dans chaque ligne de la colonne A, feuille S 02.


2) Je ne suis pas parvenu à trouver une formule courte.
Pour la Manu N°1 seule, la formule en B7, feuille Bilan, serait
=SOMME.SI.ENS('S 02'!$L$5:$L$32;'S 02'!$D$5:$D$32;$A7;'S 02'!$A$5:$A$32;B$6)
Mais si on attribue des noms définis, cela peut raccourcir sensiblement la formule :
=SOMME.SI.ENS(gain;Manu1;$A7;jour;B$6)

On peut alors la compléter, pour tenir compte des 8 manus :
=SOMME.SI.ENS(gain;Manu1;$A7;jour;B$6) + SOMME.SI.ENS(gain;Manu2;$A7;jour;B$6) + SOMME.SI.ENS(gain;Manu3;$A7;jour;B$6) + SOMME.SI.ENS(gain;Manu4;$A7;jour;B$6) + SOMME.SI.ENS(gain;Manu5;$A7;jour;B$6) + SOMME.SI.ENS(gain;Manu6;$A7;jour;B$6) + SOMME.SI.ENS(gain;Manu7;$A7;jour;B$6) + SOMME.SI.ENS(gain;Manu8;$A7;jour;B$6)
https://www.cjoint.com/c/IAka3hOtVlr
Messages postés
17
Date d'inscription
mercredi 20 décembre 2017
Statut
Membre
Dernière intervention
10 janvier 2019
2
Ouf vraiment mille merci Raymond pour ça , ça fonctionne à merveille.
Messages postés
54858
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
16 766
Tant mieux !
Mais attend une proposition plus "technique", peut-être avec une formule matricielle, ou une fonction de la catégorie [Base de données] ...
Et à bientôt.
Messages postés
54858
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
16 766
... mais rassure-toi ; quelqu'un te proposera certainement mieux que cela !