Extraire le texte de cellules a partir d'un caractere sur CALC [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
mercredi 19 décembre 2018
Statut
Membre
Dernière intervention
19 décembre 2018
-
Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
-
Bonjour,

Ne trouvant pas ma réponse pour CALC et celle d'Excel ne marchant pas, je vais tenter d'expliquer mon souci de manière clair.

j'aimerais récupérer le texte des cellules d'une collonne; le texte dans ces cellules est variable, il y a toujours deux infos de longueur variable mais qui sont séparées par ce symbole " (=guillemet) qui n apparait qu'une seule fois.
Je voudrais récupérer le texte qui se trouve avant le guillemet, sachant que le texte contenu avant varie et que le texte venant après aussi et qu'il peut y avoir d'autres symbolles (de types de séparateur ou que l'on retrouve dans les formules comme les : ou /)

Exemple de texte dans les cellules:
A1: pimpom",25/07/2018, ,
A2: boubou",àDijon 16H, ,
A3: tructrucmachin",24rueTolbiac 13:37, ,

Et ce que je veux:
A1: pimpom
A2: boubou
A3: tructrucmachin


Merci d'avance!

6 réponses

Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
4 114
Bonjour,

regarde comme cela et tu incrémentes vers le bas

on prend la virgule comme critère de séparation
=GAUCHE(A1;CHERCHE(",";A1;1)-2)

si tu as des cellules vides ajoute une gestion d'erreur
=SIERREUR(GAUCHE(A1;CHERCHE(",";A1;1)-2);"")

ou encore en prenant les guillemets comme critère de séparation
=SIERREUR(GAUCHE(A1;CHERCHE("""";A1;1)-1);"")

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64740 internautes nous ont dit merci ce mois-ci

Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
4 114
Re,

Avec Open Office les possibilités sont assez limitées et m'étonne de la compatibilité sur Open Office.
le nombre de virgule dans une chaîne ne pose pas de problème et c'est toujours la première rencontrée qui est retenue par les applications.
le principal est que tu sois arrivé à tes fins.
Je passe le statut de la discussion en résolu
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64740 internautes nous ont dit merci ce mois-ci

Messages postés
7
Date d'inscription
mercredi 19 décembre 2018
Statut
Membre
Dernière intervention
19 décembre 2018

Bonjour Mike,

Merci pour tes efforts...
J'ai collé tes formules en B1...

La première me donne Err:509 et la deuxième #NOM?

Vu que le symbolle de référence est " ça ne serait pas le détail qui coince?
Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
4 114
Re,

bizarre pour avoir testé les trois propositions sur Libre Office

travailles tu sur Libre Office ou Open Office !

Messages postés
7
Date d'inscription
mercredi 19 décembre 2018
Statut
Membre
Dernière intervention
19 décembre 2018

OpenOffice
Messages postés
7
Date d'inscription
mercredi 19 décembre 2018
Statut
Membre
Dernière intervention
19 décembre 2018

Et autre remarque, si on prend la virgule comme référence... vu qu'il peut en avoir plusieurs par ligne c'est peut etre la le blocage,,, alors que " n est présent qu'une fois (et effectivement toujours suivi d'une ,)
Messages postés
7
Date d'inscription
mercredi 19 décembre 2018
Statut
Membre
Dernière intervention
19 décembre 2018

En fait je cherche a récupérer plus de 500 mails pour souhaiter la bonne année
XXXolyne@yahoo.fr",23/08/2018 16:29, ,
XXXsa@sopena.es",23/08/2018 13:10, ,
XXXdalena.ripa@gmail.com",22/08/2018 12:30, ,

Voici d'autres idées vu q'il finissent toujours en .com, .es, .fr etc avant le fameux ",dates heures, ,
Messages postés
7
Date d'inscription
mercredi 19 décembre 2018
Statut
Membre
Dernière intervention
19 décembre 2018

Merci merci.... j'ai retenté avec succès... Mike tu me sauve.