Extraire le texte de cellules a partir d'un caractere sur CALC

Résolu/Fermé
Ruchabeille Messages postés 7 Date d'inscription mercredi 19 décembre 2018 Statut Membre Dernière intervention 19 décembre 2018 - 19 déc. 2018 à 12:12
Mike-31 Messages postés 18113 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 25 novembre 2022 - 19 déc. 2018 à 13:12
Bonjour,

Ne trouvant pas ma réponse pour CALC et celle d'Excel ne marchant pas, je vais tenter d'expliquer mon souci de manière clair.

j'aimerais récupérer le texte des cellules d'une collonne; le texte dans ces cellules est variable, il y a toujours deux infos de longueur variable mais qui sont séparées par ce symbole " (=guillemet) qui n apparait qu'une seule fois.
Je voudrais récupérer le texte qui se trouve avant le guillemet, sachant que le texte contenu avant varie et que le texte venant après aussi et qu'il peut y avoir d'autres symbolles (de types de séparateur ou que l'on retrouve dans les formules comme les : ou /)

Exemple de texte dans les cellules:
A1: pimpom",25/07/2018, ,
A2: boubou",àDijon 16H, ,
A3: tructrucmachin",24rueTolbiac 13:37, ,

Et ce que je veux:
A1: pimpom
A2: boubou
A3: tructrucmachin


Merci d'avance!

6 réponses

Mike-31 Messages postés 18113 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 25 novembre 2022 5 013
Modifié le 19 déc. 2018 à 12:38
Bonjour,

regarde comme cela et tu incrémentes vers le bas

on prend la virgule comme critère de séparation
=GAUCHE(A1;CHERCHE(",";A1;1)-2)

si tu as des cellules vides ajoute une gestion d'erreur
=SIERREUR(GAUCHE(A1;CHERCHE(",";A1;1)-2);"")

ou encore en prenant les guillemets comme critère de séparation
=SIERREUR(GAUCHE(A1;CHERCHE("""";A1;1)-1);"")

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
1