Mise en forme conditionnelle sur des cellules ayant une formule intégrée

Résolu/Fermé
jola007 Messages postés 15 Date d'inscription mercredi 7 novembre 2018 Statut Membre Dernière intervention 5 décembre 2018 - 7 nov. 2018 à 15:42
jola007 Messages postés 15 Date d'inscription mercredi 7 novembre 2018 Statut Membre Dernière intervention 5 décembre 2018 - 8 nov. 2018 à 17:01
Bonjour,

J'essai de faire la mise en forme conditionnelle suivante : ''Appliquer une mise en forme uniquement aux cellules qui contiennent, ''valeur de la cellule'' ''compris entre'' 2.50 et 100'' remplissage de la cellule en rouge.

Le problème est que la mise en forme conditionnelle, je veux l'appliquer sur ma colonne de cellules ayant une formule si intégré =SI(OU(ESTVIDE($W6);ESTVIDE($N6));"";$W6-$N6)

Toute les cellules de ma colonne sont remplis de rouge et aucune valeur n'est inscrites dans les cellules puisque mon tableau n'est pas rempli..

Je ne comprends pas pourquoi les cellules sont colorés s'il n'y a aucune valeur encore.

Pouvez-vous m'aider SVP ?

Merci !

1 réponse

eriiic Messages postés 24562 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 février 2024 7 210
Modifié le 7 nov. 2018 à 16:44
Bonjour,

la formule dans la cellule importe peu, ce qu'il faut c'est celle de ta MFC.
M'est avis que tu ne testes pas si la cellules est à ""
Et mieux encore, ton fichier (anonymisé) réduit au nécessaire.
cjoint.com et coller ici le lien fourni.
eric

0
jola007 Messages postés 15 Date d'inscription mercredi 7 novembre 2018 Statut Membre Dernière intervention 5 décembre 2018
7 nov. 2018 à 17:23
Je ne comprends pas votre explication?
0
eriiic Messages postés 24562 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 février 2024 7 210
7 nov. 2018 à 17:57
C'est pourtant en français.
Si ta MFC ne fonctionne pas, il faut fournir la formule de ta MFC
eric
0
jola007 Messages postés 15 Date d'inscription mercredi 7 novembre 2018 Statut Membre Dernière intervention 5 décembre 2018
7 nov. 2018 à 20:39
Bonjour Eric,

J'ai créé une règle pour la MFC ''Appliquer une mise en forme uniquement aux cellules qui contiennent, ''valeur de la cellule'' ''compris entre'' 2.50 et 100'' pour les cellules de ma colonne : =$AB$6:$AB$5305.
La formule intégré qui n'est pas dans la MFC est la suivante : =SI(OU(ESTVIDE($W6);ESTVIDE($N6));"";$W6-$N6).

Je crois que j'ai manqué un étape pour ce qui est de la formule dans la MFC, car je n'ai pas créé de formule mais bien une règle.

Voici le lien : https://www.cjoint.com/c/HKhtMynqTmJ

Merci de m'aider en ce qui concerne la colonne ''AB''
0
eriiic Messages postés 24562 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 février 2024 7 210
Modifié le 7 nov. 2018 à 23:10
Il faut faire la différence entre un nombre : 12 et une chaine de caractère : "12" qui est du texte comme "bonjour"
Et dans ta MFC tu écris
="2.50"
, au lieu de mettre le nombre
=2.50


Tu peux corriger les autres MFC aussi.
eric
0
jola007 Messages postés 15 Date d'inscription mercredi 7 novembre 2018 Statut Membre Dernière intervention 5 décembre 2018
8 nov. 2018 à 14:33
Bonjour,

Les '' '' se sont mises par elle-même. Je regarde les autre règle et il n'y en pas partout, je ne comprends pas le phénomène.

De plus, j'essai de corriger les autres règles en les retirant et lorsque je clique sur OK un message m’apparaît disant entrez une formule valide.

Pourtant la formule est la même que tout les autres.

Je suis très confuse.

Merci de m'aider
0