Redirection de ports sur Ethernet et Wifi [Fermé]

Signaler
Messages postés
677
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
10 juin 2020
-
Messages postés
95707
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
3 décembre 2020
-
Bonjour,

Je souhaite rediriger un port vers un de mes appareils connectés sur mon réseau local.
Je configure le DHCP de la box pour attribuer une adresse statique à cet appareil, puis je configure la redirection du port.
Le problème, c'est que les appareils ont désormais plusieurs cartes réseau : une pour l'Ethernet, et une pour le wifi. Les deux cartes ont des adresses matérielles MAC différentes.
Si je configure la redirection du port pour l'Ethernet, elle ne fonctionnera pas lorsque l'appareil est connecté en wifi (et inversement).
J'ai actuellement configuré la box en fonction du type de connexion le plus couramment utilisé, mais il n'est pas exclu que l'appareil puisse être connecté d'une autre manière dans le futur.
La box ne permet pas de configurer le DHCP pour attribuer la même adresse à deux équipements différents, et elle ne permet pas non plus de rediriger le même port externe vers plusieurs équipements.

Auriez-vous une idée pour résoudre mon problème ?

Cordialement,
E__Man.

2 réponses

Messages postés
95707
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
3 décembre 2020
11 124
Salut,
effectivement, c'est une limitation de ce mode de fonctionnement.
seule solution, mettre une adresse ip fixe sur ta connexion wifi, la même que celle de la connexion fixe, en prenat soin de désactiver l'un pour connecter l'autre, pas les deux en même temps, et de réactiver l'adresse automatique si le PC va à l'extérieur.
Mais en principe on ne fait de la redirection de port que vers un serveur, donc une machine fixe.

Messages postés
677
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
10 juin 2020
14
Je ne parviens pas à définir la même ip fixe pour la wifi et l'ethernet.

J'ai utilisé la configuration Ipv4 de Windows. J'ai renseigné l'ip de la passerelle et des serveurs DNS.
Quand je configure la deuxième carte réseau, Windows m'avertit que l'adresse ip est déjà utilisée, mais j'ignore le message.
La connexion par Ethernet fonctionne. En revanche, quand je déconnecte la câble puis que je me connecte à la wifi, je n'ai pas d'accès à Internet. La box semble refuser de m'attribuer la même ip. Celle-ci semble rester attribuée à ma carte Ethernet : même si je demande une ip dynamique à Windows et que je reconnecte mon câble, il a à nouveau l'ip que j'avais demandée auparavant.

Peut-être faut-il redémarrer la box entre chaque changement, mais cela serait vraiment contraignant.
Messages postés
95707
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
3 décembre 2020
11 124
je ne t'ai pas dit de mettre en adresse ip fixe sur les deux, juste sur la connexion wifi.
et bien sûr, encore une fois, tu n'utilises qu'une seule à la fois, c'est à dire que tu désactives l'autre.