Erreur dans formule [Résolu/Fermé]

Signaler
-
 Elia75 -
Bonjour,
Je remercie d'avance les personnes qui pourront m'aider. A chaque fois, ce forum m'a été très utile.
Voici ma formule : =SI(ESTTEXTE($O$2);RECHERCHEV($O$2;$AG$1:$AK$664;1);Planning!$N$1)
J'obtiens bien la recherche du mot en O2 dans mon tableau en AG/AK et une réponse qu'excel récupère dans la colonne 1. Par contre, la réponse n'est pas la bonne. Par exemple, en O2, j'inscris Noël au Portugal. La réponse qui se situe dans le tableau est "Spectacle". mais j'obtiens "Exposition" (mot qui se situe dans la même colonne mais plusieurs ligne plus haut.
Est-ce que vous pouvez m'indiquer mon erreur s'il vous plait ?

1 réponse

Messages postés
2645
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
28 mai 2020
661
Bonjour

=SI(ESTTEXTE($O$2);RECHERCHEV($O$2;$AG$1:$AK$664;1);Planning!$N$1)

La colonne 1 du tableau de recherche est la colonne de correspondance de la valeur cherchée(trouver le texte O2 dans la colonne AG) , il faut donc mettre le numéro de la colonne où chercher la réponse qui correspond (AH=2 - AI=3 - AJ=4 - AK=5).

Cordialement
Merci. Je change l'ordre de mes colonnes.