Formule SI qui utilise des résultats de formule

Résolu/Fermé
Signaler
-
Messages postés
1
Date d'inscription
vendredi 17 août 2018
Statut
Membre
Dernière intervention
17 août 2018
-
Bonjour,

J'ai un petit soucis de calcule sur une formule SI.
Les formules sont les suivantes :
=SI(E23>0;2;SI(E22>0;1;0))
et =SI(E23>M20;(C23-E23);SI(E22>M20;(C22-E22);(J17-E21)))

Le problème est que E23 et E22 sont des formules :
E22 = SI(E21=E24;"0";SI((E24-E21)>C21;C21;(E24-E21)))
E23 = SI((E21+E22)=E24;"0";SI((E24-E21-E22)>C21;C21;(E24-E21-E22)))

Ecxel considère que E23 étant une formule
pour la 1ere : E23>0 est FAUX et il m’affiche 2
pour la 2eme : E23>M20 est FAUX et il fait la soustraction C23-E23 (qui elle se fait très bien!)

Les 2 formules sont justes car lorsque je mais des chiffres à la place des formules sur les cellule E23 et E22 elles fonctionnent très bien.

Tout les cases concernées par les formules sont en "nombre".

Avez-vous une solution pour me débloquer?

Merci d'avance
(Désolé si le sujet à déjà été abordé)

2 réponses

Messages postés
26318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2021
6 135
Bonjour
la fonction travaille avec les résultats, pas avec les formules
=SI(E23>0;2;SI(E22>0;1;0))
est une fnction correcte qui renvoie en priorité 2 si le résultat de E23 est plus grand que 2, seulement ensuite 1 si E22 est plus grand que 1 et enfin 0 si aucune conditions n'est réalisée
Mais ne mettez pas les résultats (réputés numériques) entre guillemets dans les formules, car pour Excel, cela devient des textes et enlevez les poignées de parenthèses superflues:
= SI(E21=E24;0;SI(E24-E21>C21;C21;E24-E21))
et l'item E21=E24;0 est inutile puisque dans ce cas, la dernière condition renverra forcément 0
=SI(E24-E21>C21;C21;E24-E21) devait suffire

et pour la suivante:
=SI(E21+E22=E24;0;SI(E24-E21-E22>C21;C21;E24-E21-E22))

crdlmnt

Messages postés
1
Date d'inscription
vendredi 17 août 2018
Statut
Membre
Dernière intervention
17 août 2018

Merci beaucoup!!!!
Effectivement sans les guillemets tous fonctionne très bien !!! Les parenthèses en trop était pour essayer de régler le problème, elles sont complètement inutile en effet.

Cordialement,
Bonne soirée