Comment lier une formule sur différents onglets [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
jeudi 26 juillet 2018
Statut
Membre
Dernière intervention
26 juillet 2018
-
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
-
Bonjour,

Actuellement, mes collègues doivent encoder Les memes données (Nbre heures prestées, N° de Tournée, ...) sur différents fichiers.

Idéalement, j'aimerai qu'ils ne doivent réaliser qu'une seule fois l'encodage en partant de la feuille PLANNING.
Le hic, c'est que ce fichier PLANNING comporte un onglet par jour.

J'aimerai utiliser la fonction RECHERCHEV, pour aller repercuter les valeurs de chaque encodage en partant de la feuille PLANNING, mais je ne sais pas comment faire pour automatiser la référence à différents onglets...

Est ce que quelqu'un aurait une idée ???

Merci d'avance =)

Thomas

4 réponses

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
Bonjour
difficicile d'être précis avec seulement ces données
toutefois pour le principe
par exemple:
un nom d'onglet entré en A1 strictement identique au nom de la feuille
pour effertuer une recherche en A:C de l'onglet nommé et ressortir C

=RECHERCHEV(cell valeur cherchée; INDIRECT("'"&A1&"'!A:C");3;0)

qui ira cvhercher dans l'onglet nommé en A1
crdlmnt

Messages postés
4
Date d'inscription
jeudi 26 juillet 2018
Statut
Membre
Dernière intervention
26 juillet 2018

Bonjour Vaucluse,

Merci pour la réponse rapide.
Voici les fichiers en question.

Lien vers fichier PLANNING (depuis lequel il faut aller chercher les données)
https://drive.google.com/file/d/1MSgmbbQqTYTjZjMxoLAI5LSHqZJp87tK/view?usp=drive_open

Lien vers fichier REGIE (vers lequel il faut copier les données - exemple, en se basant sur le N° du camion)
https://drive.google.com/file/d/1y8RzmWGLXEpxb5TIiUAuug3yFo0c82Zx/view?usp=drive_open

Je vais tester avec votre fonction pour voir ce que ça donne =)
Messages postés
4
Date d'inscription
jeudi 26 juillet 2018
Statut
Membre
Dernière intervention
26 juillet 2018

ha oui, evidemment ça ne fonctionne pas, etant donné que les données se trouvent dans 2 fichiers différents ... d'autres idées ?
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
Re
essayez cette formule en D5 qui semble faire ce que vous cherchez
(le )5; étant à ajuster sur les autres colonnes en fonction de la valeur à ressortir)

=SIERREUR(RECHERCHEV(B5;INDIRECT("'[PLANNING 07-2018.xlsx]"&GAUCHE(TEXTE(C5;"jjmm");4)&"'!B12:M100");5;0);"")

attention à tous les signes, notamment guillemets et apostrophes dans la code INDIRECT

pour teste de vérification ci besoin, dans cellule hirs champ)

="'[PLANNING 07-2018.xlsx]"&TEXTE(C5;"jjmm")&"'!B12:M100"
doit renvoyer en texte l'adresse complète
et
=INDIRECT("'[PLANNING 07-2018.xlsx]"&GAUCHE(TEXTE(C5;"jjmm");4)&"'!B12")
doit renvoyer la valeur de B12 du fichier PLANNING


il est possible de compléter cette adresse variable comme suit pour accéder à d'autres fichiers mensuels avec cette formule en D5:

=SIERREUR(RECHERCHEV(B5;INDIRECT("'[PLANNING "&TEXTE(MOIS(C5);"00")&"-"&ANNEE(C5)&".xlsx]"&TEXTE(C5;"jjmm")&"'!B1:M1000");5;0);"")

si bien entendu dans tous les cas, les classeurs correspondants sont ouverts

crdlmnt


Messages postés
4
Date d'inscription
jeudi 26 juillet 2018
Statut
Membre
Dernière intervention
26 juillet 2018

Wahhhhhhhhhhhhhhhhhhhhhhh ça fonctionne !!!!!!!!!!
tout simplement MERCI :):):):):):)

Je vais etudier les fonctions que vous avez utilisé pour comprendre !

C'est tout simplement SUPER !!!!

MERCI MERCI MERCI

Thomas
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt