Formule pour rechercher un nombre [Résolu/Fermé]

Signaler
Messages postés
62
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
31 mars 2020
-
Messages postés
62
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
31 mars 2020
-
Bonjour,

J'ai un tableau comme ceci :


Les années sont présentes dans une liste déroulante.
Quelle formule dois-je utiliser si je veux qu'une cellule affiche le nombre correspondant à l'année quand je la sélectionne (ex : 2018 --> 1, etc) ?

J'ai essayé recherche, recherchev, rechercheh, index et equiv mais aucune de ces formules ne marche.

Merci !

5 réponses

Messages postés
5508
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 septembre 2020
482
Bonjour


La colonne A les années
la colonne B les valeurs

=RECHERCHEV(C2;A2:B12;2;faux)
on cherche la valeur de l'année présente en cellule C2
dans la plage de cellules A2 à B12
on retourne l'information de la colonne 2 (colonne B)
on veut la valeur correspondant exactement à C2



Messages postés
29558
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
17 septembre 2020
2 779
Bonjour,

Les deux fonctions peuvent être utilisées :




Après.... sans savoir ce que vous avez testé exactement... difficile de vous dire où vous vous êtes trompé !
Messages postés
25287
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 septembre 2020
5 467
Bonjour
si vous voulez afficher le résultat "uniquement quand vous sélectionnez la cellule" il faudra passer par VBA
et nous dire où vous voulez le résultat
crdlmnt
Messages postés
52273
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 septembre 2020
14 063
Si les années sont en colonne A:A tu peux utiliser la formule =A:A-2017
Si l'année est placée dans la cellule A2, ce sera la formule =A2-2017

C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
Messages postés
62
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
31 mars 2020

Merci à vous c'est parfait ! :D