Formule pour rechercher un nombre

Résolu/Fermé
andy2092
Messages postés
69
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
7 juin 2021
- 24 juil. 2018 à 16:36
andy2092
Messages postés
69
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
7 juin 2021
- 25 juil. 2018 à 14:29
Bonjour,

J'ai un tableau comme ceci :


Les années sont présentes dans une liste déroulante.
Quelle formule dois-je utiliser si je veux qu'une cellule affiche le nombre correspondant à l'année quand je la sélectionne (ex : 2018 --> 1, etc) ?

J'ai essayé recherche, recherchev, rechercheh, index et equiv mais aucune de ces formules ne marche.

Merci !

5 réponses

PHILOU10120
Messages postés
6091
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
7 août 2022
728
Modifié le 24 juil. 2018 à 16:51
Bonjour


La colonne A les années
la colonne B les valeurs

=RECHERCHEV(C2;A2:B12;2;faux)
on cherche la valeur de l'année présente en cellule C2
dans la plage de cellules A2 à B12
on retourne l'information de la colonne 2 (colonne B)
on veut la valeur correspondant exactement à C2



0
jordane45
Messages postés
36036
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
9 août 2022
4 273
24 juil. 2018 à 16:49
Bonjour,

Les deux fonctions peuvent être utilisées :




Après.... sans savoir ce que vous avez testé exactement... difficile de vous dire où vous vous êtes trompé !
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
24 juil. 2018 à 16:49
Bonjour
si vous voulez afficher le résultat "uniquement quand vous sélectionnez la cellule" il faudra passer par VBA
et nous dire où vous voulez le résultat
crdlmnt
0
Raymond PENTIER
Messages postés
56471
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 août 2022
17 193
Modifié le 24 juil. 2018 à 17:24
Si les années sont en colonne A:A tu peux utiliser la formule =A:A-2017
Si l'année est placée dans la cellule A2, ce sera la formule =A2-2017

C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
andy2092
Messages postés
69
Date d'inscription
dimanche 13 mai 2018
Statut
Membre
Dernière intervention
7 juin 2021

25 juil. 2018 à 14:29
Merci à vous c'est parfait ! :D
0