Plusieurs tests logiques et conditions fonction SI [Fermé]

Signaler
-
 Amy -
Bonjour,
J'aimerai faire une formule avec plusieurs conditions et plusieurs tests logiques. J'arrive à faire les deux séparément mais pas les deux en même temps :/

Cela donne ça textuellement : SI J2<80 et J3=1 et J4<22 alors "A" sinon "B" puis SI J2<80 et J3=2 et J4<23 alors "A" sinon "B" ... et ainsi de suite j'ai 8 tests à faire...

Pouvez-vous m'aider à résoudre mon problème ?
En vous remerciant.

1 réponse

Messages postés
52629
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
14 547
Bonjour.

Pour un seul test tu as donc, je suppose,
=SI(ET(J2<80;J3=1;J4<22);"A";"B")

Pour trois tests tu auras alors
=SI(OU(ET(J2<80;J3=1;J4<22);ET(J2<80;J3=2;J4<23);ET(J2<90;J3=6;J4<25));"A";"B")

Si tu précisais les données pour les 8 tests (et pas seulement les deux premiers) on pourrait peut-être déceler des simplifications possibles ...
Votre solution marche à merveille ! Je vous remercie. Effectivement il serait bien de trouver des simplifications car je vais avoir besoin de refaire la même chose avec beaucoup plus d'éléments.

Voici la formule que j'ai réussi à faire : =SI(OU(ET(C1<80;C2=1;C3<22);ET(C1<80;C2=2;C3<23);ET(C1<80;C2=3;C3<25);ET(C1<80;C2=4;C3<26);ET(C1>80;C2=1;C3<21);ET(C1>80;C2=2;C3<22);ET(C1>80;C2=3;C3<24);ET(C1>80;C2=4;C3<25));"Pathologique";"Normal")
Messages postés
8246
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 518
Peut-être :
=SI(C3-(C1<80)-C2<21;"Pathologique";"Normal")
Messages postés
52629
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
14 547
Amy, je peux t'assurer que tu ne trouveras pas mieux !
Bravo à Patrice, encore une fois ...
Merci beaucoup Patrice et Raymond ! Cela marche parfaitement grâce à vous deux !