Ignorer les cellules vides (fonction SI) [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mercredi 6 juin 2018
Statut
Membre
Dernière intervention
6 juin 2018
-
Messages postés
2
Date d'inscription
mercredi 6 juin 2018
Statut
Membre
Dernière intervention
6 juin 2018
-
Bonjour,

Dans un tableau je dois comparer toutes les chaines de caractère qui apparaissent sur la même ligne, pour savoir si elles sont toutes identiques ou non.

Le tableau ressemble à ça (les lettres étant des chaines de caractère) :



Pour l'instant, j'ai donc cette formule dans "Vérif"

=SI(ET(A2=C2;A2=E2;C2=E2);"OK";"KO")

Le problème, c'est que certaines cellules sont vides, et que les cellules à comparer ne sont pas toujours sur les mêmes colonnes.

Donc par exemple, si je devais faire tout à la main, je me retrouverais avec une colonne de ce genre :

=SI(ET(A2=C2;A2=E2;C2=E2);"OK";"KO")
=SI(ET(B3=D3;B3=E3;D3=E3);"OK";"KO")
=SI(ET(B4=D4;B4=E4;D4=E4);"OK";"KO")
...

Ce qui est un peu long, surtout qu'il y a des milliers de lignes...

Du coup, ma question :
Est-ce qu'il existe une formule pour comparer les lignes entières en ignorant les cellules vides ?

Merci !
Bonne soirée :)

2 réponses

Messages postés
16212
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 septembre 2020
3 035
Bonjour

=SOMME(SI(A2:E2<>"";1/NB.SI(A2:E2;A2:E2)))

te donne le nombre d’occurrences


si tu obtiens 1 c'est OK
si(SOMME(SI(A2:E2<>"";1/NB.SI(A2:E2;A2:E2)))=1;"0K";"KO")

ATTENTION:
Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule. La formule est alors encadrée automatiquement par des accolades : { formule }



Messages postés
2
Date d'inscription
mercredi 6 juin 2018
Statut
Membre
Dernière intervention
6 juin 2018

Merci beaucoup !!