[Ubuntu] impossible de mettre mon mot de passe

[Fermé]
Signaler
-
Messages postés
30102
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 septembre 2021
-
Bonjour je n'arrive plus a re ouvrir mon pc que j'ai formaté hier pour mettre linux ubintu,
a cause du mot de passe qu'il ne prends plus
je peux pas mettre mon clavier en français définitivement t'en que je suis pas entré dans mon pc ,

alors comment allez sur système etc pour réglé le problème svp? une réponse rapide serait bienvenu merci d'avance Eddy
A voir également:

4 réponses

Messages postés
30102
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 septembre 2021
7 172
Bonjour,

Méthode 1 : plus compliquée, mais de réinstallation

Assure-toi que le clavier est bien azerty ou qwerty comme tu le crois en tapant quelques lettres dans la case de login. Idéalement tu peux même voir si tu arrives à retaper ton mot de passe et trouver les "bonnes touches" pour taper ton mot de passe. Ceci fait, tape ton login dans la case correspondante, et ton mot de passe dans la case correspondante et identifie-toi.

Le "layout" (la disposition des touches) ne peut se régler qu'une fois identifié (soit en root, soit sous ubuntu avec l'utilisateur principal pour pouvoir utiliser sudo). Ensuite, la disposition du clavier se corrige comme indiqué dans ce tutoriel :

Mode texte :

sudo dpkg-reconfigure console-data
sudo dpkg-reconfigure keyboard-configuration
sudo service keyboard-setup restart


Mode graphique :

Il faut distinguer trois réglages :
1) la disposition utilisée au moment de t'identifié (on appelle le logiciel en question "gestionnaire de connexion", et en général il s'agit de lightdm ou sddm);
2) la disposition utilisée par défaut par le serveur graphique ;
3) la disposition utilisée dans ta session personnelle (que tu peux configurer via le panneau de configuration);

A priori, il suffit de corriger
/etc/default/keyboard
devrait suffire (par exemple avec la commande
gksudo gedit /etc/default/keyboard &
) pour régler les deux premiers points. Voici le contenu de ce fichier chez moi :

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="latin9"
XKBOPTIONS=""

BACKSPACE="guess"


Méthode 2 : réinstallation

Vu que tu viens d'installer, tu n'as pas grand chose à perdre à réinstaller. Tant qu'à faire, prends une version française d'ubuntu pour que tout (y compris la langue et le clavier) soit réglés en conséquence.
https://ubuntu.com/

Attention avant de réinstaller. Sauvegarde tes données précieuses sur un autre support (clé USB, disque USB, DVD etc...) et veille à ne pas formater les partitions auxquelles tu tiens au moment du partitionnement. En outre, se reposer sur le partitionnement automatique peut réserver de mauvaises surprises si on ne fait pas attention. Pour plus de détails, voir ici.

Bonne chance
Bonjour Mamiemando

Merci pour ta réponse c'est très sympa,
J'ai finalement re re re formaté et là impeccable avec un mot de passe court ça marche bien.

Mais c'est une vraie galère pour installer une application à part celles directement fournies sous ubuntu. Le kodi est vieux. Pour installer une version récente j'ai mis deux jours, et encore un pro de linux la pris la main a distance. Il a mis 4 h Une fois le 17.6 installé, il s'ouvre mais ne marche pas !!

Ensuite j'ai acheté une clef wifi] parce que j'ai la fibre avec maxi 1645 de puissance. Avant j'avais que 11 mega et même avec le CD impossible d'installer la clef. Donc obligé de me connecter en filaire et pareil pour un anti virus.

Et pourtant je passe par où il faut pour installer tout ça. Dommage j'ai dû retourner a Windows 7, comme beaucoup je pense. Après 3 jours de galère pour des trucs que je fais en 10 mn d'habitude...

Voila merci pour ton aide j'ai gardé le disque dur avec linux installé dessus. À voir avec le temps qui sait !!!

Cordialement
Eddy
Messages postés
30102
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 septembre 2021
7 172
Bonjour Eddy

Merci pour ton message, attention à soigner l'orthographe et à la ponctuation dans tes prochains messages, car tu n'es pas facile à lire. Je te fais juste quelques petits retours sur ton message, après bien entendu il faut utiliser le système et les logiciels que tu estimes les plus pratiques.

Sous linux, il y a clairement une étape de prise en main quand on vient du monde de windows, car la logique n'est pas la même. C'est bien que tu trouves ça simple d'installer les logiciels fournis par la logithèque car c'est la manière standard d'installer un programme. En fait les autres manière ne sont pas standards (et même sont à éviter si le programme est disponible dans la logithèque).

Une fois linux pris en main, je trouve que c'est plus simple d'utiliser linux que windows. Par exemple pour installer kodi sous debian ou ubuntu :
sudo apt-get install kodi
et c'est fini. Pas besoin d'aller sur des sites, se manger des pubs, et de cliquer partout :-) Note que si tu utilises une distribution récente ce sera kodi 17.6. Je ne sais pas si c'est "récent" ou pas mais ça semble correspondre à ce que tu semblais attendre.

Les environnements et applications sous linux plus agréables et plus complets (cf plasma5 pour l'environnement, clementine pour écouter de la musique, smplayer pour regarder des vidéos, kmail pour le mail). Certains logiciels (e.g. chromium, la version libre de chrome) s'installe beaucoup plus facilement sous linux que sous windows (notamment si tu veux un support correct de flash). Bref, selon ce que tu veux faire, c'est parfois plus facile sous linux que windows.

Concernant les dongles wifi, le mieux est de se renseigner avant d'en acheter une. L'installation est plus ou moins aisée, mais en théorie dans les cas désespérés on peut s'en sortir avec ndiswrapper. Mais si tu utilises des cartes wifi standards (e.g. des cartes intel, celles traditionnellement utilisées sur les portables), c'est encore une fois un paquet à installer (sous debian :
sudo apt-get install firmware-iwlwifi
, sous ubuntu rien à faire).

Pour le grand public (en particulier les gamers), windows est un choix a priori plus simple. Il faudra simplement à être vigilant en matière de malwares, virus et de pare-feu, là où sous linux on est bien plus tranquilles. Linux est à mon avis, surtout intéressant pour les développeurs, les gens qui souhaitent avoir un système libre et open source, et pour les personnes qui possèdent des ordinateurs trop anciens pour faire tourner convenablement des versions modernes de windows.

Bonne continuation !
Salut,

@mamiemando,

J'ai un peu le mème avis concernant les dépôts de logiciels dont les versions sont obsolètes. J'ai l'impression qu'il n'y a pas réellement de suivi. J'ai eu la même galère avec Kodi (version obsolète dans le synaptic) alors qu'en passant par le site kodi on peut installer la dernière version qui marche parfaitement. C'est ce genre de détail qui peut pousser une personne à fuir linux.

Autre cas, quand on utilise Bleachbit et que l'on a Firefox Quantum, ce logiciel te donne plein de messages d'erreur.
La raison? La version proposé dans les dépôts est obsolète et donc obligé d'aller sur le site Bleachbit pour prendre la dernière version.............et là, ça marche.

De plus, au contraire de toi, quand je passe par le terminal que je ne trouve pas pratique, on me refile toujours ceux qui sont listés dans le synaptic. J'avoue que cela devient chiant au final.

Voila, c'était mon petit coup de gueule.

Ps: Merci à toi, de prendre sur ton temps pour nous aider.
Messages postés
30102
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 septembre 2021
7 172
Bonjour gori,

Le problème que tu soulèves est intéressant et légitime, je vais donc prendre quelques lignes pour tenter de t'expliquer pourquoi les choses sont comme ça. Même si ça ne réglera pas le problème dont tu parles :-)

Réponses courtes :
- Concernant les versions obsolètes dans les dépôts : cela dépend quelle release tu utilises.
- Concernant synaptic et le terminal : c'est normal, puisque tout deux dépendent du gestionnaire de paquets (apt)
- Concernant les histoires de "dernières versions" : ce n'est techniquement pas réalisable de faire mieux que ce qu'on a.

Réponses détaillées : voir les paragraphes associés.

Les releases

Par exemple si tu es sous debian unstable, tu auras les dernières versions, mais celles-ci ne seront pas aussi éprouvées que si tu es sous debian testing ou debian stable (si je prends l'exemple de debian). Le même genre de raisonnement s'applique aux autres distributions (cf release de la distribution).

Exemple :
- stable (stretch) : https://packages.debian.org/stretch/kodi
- testing (buster) : https://packages.debian.org/buster/kodi
- unstable (sid) : https://packages.debian.org/sid/video/kodi

Le gestionnaire de paquets

Le fait que le terminal te propose la même chose que synaptic est parfaitement normal : synaptic repose sur apt, et apt est justement l'outil qui s'appuie sur les dépôts. Ce sont des "packages managers", qui s'appuient précisément sur les listes de paquets et paquets mis à dispositions par les dépôts de ta distribution. Un tel outil nécessite de savoir où les chercher (c'est ce qui est réalisé par /etc/apt/sources.list en l'occurrence).

Par défaut ton gestionnaire de paquets est configuré pour interroger les dépôts correspondants à ta distribution

Pourquoi le gestionnaire de paquets ne propose pas la dernière version ?

Pour qu'un gestionnaire de paquets fournisse exactement la dernière version de chaque logiciel, ce serait très compliqué voire irréalisable :
1) Il faudrait que chaque projet expose un dépôt apt (au même titre que ta distribution), or les développeurs n'ont pas forcément l'infrastructure nécessaire ni envie de supporter un miroir par gestionnaire de paquets
2) Il faudrait que chacun de ces dépôts soit connus et référencés dans ton gestionnaire de paquets (comment gérer ça lorsqu'un nouveau projet apparaît / disparaît / propose une nouvelle version) ?
3) Les paquets sont (sous les distributions dignes de ce nom, dont debian et ubuntu) signés par les mainteneurs de la distribution (clé que n'ont pas les développeurs de part le monde)
4) Il n'y aurait pas de garantie sur la compatibilité entre les différentes dernières versions de chaque logiciel

Aujourd'hui, ce problème est traité en laissant à chaque distribution d'avoir ses propres miroirs, ces propres mainteneurs (pour préparer les paquets, leurs dépendances, ...), chacun responsable d'un certains nombre de logiciels et de vérifier que les paquets qu'ils gèrent se comportent comme prévus. En cas d'erreur, les bug reports sont là.

En résumé, il serait difficile d'aller vers une solution "meilleure" et réaliste à la fois. Il reste possible au travers des outils de bug report de demander (gentiment) aux développeurs une version plus récente (wishlist).

Exemple : https://bugs.debian.org/cgi-bin/pkgreport.cgi?src=kodi

Il ne faut pas oublier que la plupart des développeurs et mainteneurs sont des bénévoles. Toute aide est la bienvenue. Ceci veut aussi dire qu'il est un peu "injuste" de faire des reproches sur le travail de personnes qui sacrifient une partie de leur temps libre.

Une approche possible pour améliorer les choses serait de contribuer, par exemple en tentant de devenir à son tour mainteneurs de sa distribution préférée et ainsi mettre à disposition des paquets qui suivent mieux les dernières version de chaque logiciel. Les mainteneurs s'occupent généralement d'un nombre restreints de paquets et peuvent par exemple se concentrer sur les projets qui leur tiennent à coeur.

Bonne chance