Formule dans tableau (création variable?)

Résolu/Fermé
Messages postés
58
Date d'inscription
mercredi 2 avril 2014
Statut
Membre
Dernière intervention
8 novembre 2018
-
Messages postés
58
Date d'inscription
mercredi 2 avril 2014
Statut
Membre
Dernière intervention
8 novembre 2018
-
Bonjour,

Heure (à remplir manuellement) | temps (calculé)
09:30 | -
10:30 | 01:00
10:40 | 00:10

Dans ce tableau, ou je calcule le temps de chaque étape (1 étape = 1 ligne) en 2 ieme colonne selon la formule "A3-A2"etc. Tout va bien jusque la.

Par contre, je souhaite introduire le fait que lorsqu'on ne renseigne pas d'heure, il n'y a pas de calcul de fait.

09:30 | -
10:30 | 01:00
10:40 | 00:10
- | 00:00
- | 00:00
11:40 | 01:00

l'exemple ci-dessus serait le résultat souhaité.
J'ai réussi à le faire en créant une autre colonne.
Je me demandais si il était possible de le faire, sans créer une autre colonne, par l'apport d'une variable par exemple.

Merci d'avance pour vos réponses,

1 réponse

Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 260
Bonjour

une piste sans VBA (A1 non numérique)
=SI(A2=0;"";A2-MAX(A1:A$2))
à tirer vers le bas

Et si tu tiens à du VBA
Option Explicit
'-----------------------------------------
Sub ww()
Dim Derlig As Integer
Derlig = Columns("A").Find(what:="*", searchdirection:=xlPrevious).Row
Range("B2").FormulaLocal = "=SI(A2=0;"""";A2-MAX(A1:A$2))"
Range("B2").AutoFill Destination:=Range("B2:B" & Derlig), Type:=xlFillDefault
End Sub


Messages postés
58
Date d'inscription
mercredi 2 avril 2014
Statut
Membre
Dernière intervention
8 novembre 2018

Merci beaucoup pour ta réponse logique (que je n'ai pas eu)