Problème pour formule NB.SI

Résolu/Fermé
nyco12 Messages postés 28 Date d'inscription samedi 20 février 2016 Statut Membre Dernière intervention 31 juillet 2021 - Modifié le 2 mars 2018 à 13:52
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 9 mars 2018 à 20:54
Bonjour à tous,

Je fais appel à vous, les experts d'Excel car je souhaiterais faire une formule NB.SI qui prendrait en compte les données inscrites sur plusieurs feuilles d'un même classeur.


Voici la formule NB.SI que j'ai faite sur la feuille dénommée "MARS 2017" =NB.SI(A1:L60;"LIBRE")
Celle-ci fonctionne parfaitement (en même temps rien de plus facile)

En revanche j'aimerais pouvoir, plutôt que de faire cette formule sur toute les feuilles du classeur et ensuite d'additionner le résultat, faire une formule NB.SI dans la feuille récap. qui irait rechercher sur la même plage (A1:L60) de toutes les feuilles du classeur, le même mot "LIBRE"

Le nom des feuilles sont par exemple : MARS 2017, AVRIL 2017, MAI 2017....

Pouvez vous m'aider sur ce point.


Merci d'avance pour toutes vos réponses.

Bien amicalement.
Nyco

5 réponses

PHILOU10120 Messages postés 6170 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 24 novembre 2022 744
2 mars 2018 à 19:30
Bonjour Nico12

Une idée

=NB.SI('mars 2017'!A1:L60;"libre")+NB.SI('avril 2017'!A1:L60;"libre")+NB.SI('mai 2017'!A1:L60;"libre")

vous additionnez les douze feuilles
0
nyco12 Messages postés 28 Date d'inscription samedi 20 février 2016 Statut Membre Dernière intervention 31 juillet 2021
2 mars 2018 à 22:37
Merci Philou,

C'est une solution, pas moyen en revanche de mettre quelque chose comme :
=NB.SI('mars 2017':'mai 2017'!A1:L60;"libre") ?

Merci de votre aide !
0
nyco12 Messages postés 28 Date d'inscription samedi 20 février 2016 Statut Membre Dernière intervention 31 juillet 2021
Modifié le 5 mars 2018 à 22:52
Bonjour à tous,

1/J'ai cru voir sur certains forums que nous pouvions créer la formule NB.SI.3D ?
Celle-ci me servirait à savoir combien de fois la valeur "LIBRE" est inscrite dans le classeur entier sur les onglets nommés de Janvier à Décembre.

Cela m'éviterait de créer des tonnes de formules dans chacun des onglets et ensuite de les additionner. (J'ai excel 2013)

2/ Sur chaque onglets, j'ai le numéro de la semaine avec un nombre d'heure.
exemple, dans la cellule A15 "TOTAL SEMAINE 5" et en cellule G15, le nombre d'heure s'y référant.
Je souhaiterais mettre dans le récap que si dans le classeur la cellule s'appelle "TOTAL SEMAINE 5" qu'il me copie les heures y figurant afin de faire un global sur l'année.

Pouvez vous m'aider svp ?

Merci à tous de votre aide.

Nyco
0
via55 Messages postés 13965 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 27 novembre 2022 2 520
5 mars 2018 à 23:06
Bonsoir Nico

Avec la formule de Jacques Boisgontier (voir d'autres exemples sur son site):
Dans la feuille RECAP mettre par exemple en A1:A12 les noms des 12 onglets, puis dnas une cellule la formule :
=SOMMEPROD(NB.SI(INDIRECT($A$1:$A$12&"!A1:L60");"LIBRE"))

Cdlmnt
Via
0
eriiic Messages postés 24463 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 23 novembre 2022 7 142
5 mars 2018 à 23:27
Bonjour,

tu peux aussi mettre ton nb.si() sur chaque feuille et faire une somme 3D.
eric
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Jauster Messages postés 126 Date d'inscription jeudi 7 décembre 2017 Statut Membre Dernière intervention 31 août 2018 30
Modifié le 5 mars 2018 à 23:55
Bonsoir,

En utilisant une Function à insérer dans un module :

Function monNbSi(rng As Range, criteria) As Long
    Dim ws As Worksheet

    For Each ws In ThisWorkbook.Worksheets
        'If ws.name <> "Feuil1" And ws.name <> "Feuil2" Then 'si tu souhaites éviter certaines feuilles
            monNbSi = monNbSi + WorksheetFunction.CountIf(ws.Range(rng.Address), criteria)
        'End If
    Next ws
End Function



S'utilise ainsi : =monNbSi(plage;critère), donc =monNbSi(A1:L60;"LIBRE")
0
nyco12 Messages postés 28 Date d'inscription samedi 20 février 2016 Statut Membre Dernière intervention 31 juillet 2021
Modifié le 6 mars 2018 à 19:58
Bonsoir Jauster,

Merci déjà de ton aide.
J'ai bien crée ma fonction mais lorsque je veux la mettre en application comme tu me l'as écrit.
Il me met le message d'erreur suivant.

"Attention votre classeur contient une ou plusieurs références circulaires qui risquent d'entraîner des erreurs de calcul dans vos formules."

Pouvez vous de nouveau me venir en aide.
Merci d'avance.

Nyco.
0
Jauster Messages postés 126 Date d'inscription jeudi 7 décembre 2017 Statut Membre Dernière intervention 31 août 2018 30 > nyco12 Messages postés 28 Date d'inscription samedi 20 février 2016 Statut Membre Dernière intervention 31 juillet 2021
6 mars 2018 à 20:47
Salut, peux-tu joindre le fichier ici ? merci
0
nyco12 Messages postés 28 Date d'inscription samedi 20 février 2016 Statut Membre Dernière intervention 31 juillet 2021 > Jauster Messages postés 126 Date d'inscription jeudi 7 décembre 2017 Statut Membre Dernière intervention 31 août 2018
6 mars 2018 à 21:11
Oui je peux bien sur mais (je n'ai pas ouvert mes yeux) je ne trouve pas comment joindre le fichier... :-/
Peux tu m'aider ? Merci d'avance
0
Jauster Messages postés 126 Date d'inscription jeudi 7 décembre 2017 Statut Membre Dernière intervention 31 août 2018 30
6 mars 2018 à 21:26
https://wetransfer.com/
Et il faut ensuite partager le lien ici
0
nyco12 Messages postés 28 Date d'inscription samedi 20 février 2016 Statut Membre Dernière intervention 31 juillet 2021
6 mars 2018 à 21:29
Voici : https://we.tl/6j1sDXDJDh
Merci de ton aide.
0