Formule (recherche?

[Résolu/Fermé]
Signaler
Messages postés
91
Date d'inscription
lundi 23 août 2004
Statut
Membre
Dernière intervention
20 mars 2018
-
Messages postés
91
Date d'inscription
lundi 23 août 2004
Statut
Membre
Dernière intervention
20 mars 2018
-
Bonjour
J’essaie de faire un planning colonne B à AG
J’ai un problème avec une formule.
Sur la ligne 3 j’ai les dates qui commencent toujours par le 1er de chaque mois
Sur la ligne 4 j’ai les jours
Et dans la colonne A j’ai des noms.
Alors je dois rechercher toute les cellules de la ligne 5 qui corresponde au lundi pour faire l’addition dans la colonne AI J’ai très difficile de m’expliquer.
Pour le mois de Janvier pas de problème car le lundi est le premier jour de la semaine mais pour le mois de février sa change, Déjà.
Si quelqu’ un pourrais encore m’aider sa serais super.
Merci
Josiane
https://www.cjoint.com/c/HCchTsjYMyq

2 réponses

Messages postés
2706
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 septembre 2021
1 648
Bonjour,

Voici le lien de ce que j'ai compris
https://www.cjoint.com/c/HCcipDfl1CT

Le but étant de cherche par rapport a la formule JourSem qui renvoi ... comme son nom l'indique le jour de la semaine:)

Combiner avec un sommeprod qui est en quelque sorte une formule Si Beaucoup plus puissante

Il faut juste verrouillé la ligne du haut dans laquelle il y a vos jours

Voir votre tableau de février
Messages postés
91
Date d'inscription
lundi 23 août 2004
Statut
Membre
Dernière intervention
20 mars 2018

Bonjour, je suis nul je n’arrive pas à comprendre
Diablo
Pour le mardi sa fonctionne pas il marque valeur.
Merci
Messages postés
2706
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 septembre 2021
1 648
Bonjour,

Voici avec ma formule pour tous les jours de la semaine.

https://www.cjoint.com/c/HCcm0OAO3BT

J'ai verouillé directement la ligne entiere des jours.
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 053
Bonjour

si j'ai bien compris, mais ça n'est pas sur, le plus simple:

par exemple pour votre 1° tableau
dans la ligne 24 de B24 à AF24 cette formule:
=JOURSEM(B4;2) à tirer vers la droite
et ensuite pour les calculs:
=SOMME.SI($B$224:$AF$24);1;B5:AF5)


ou une solution plus directe, mais pour qu'elle fonctionne il faudrait que votre formule qui remplit le tableau renvoie 0 pour les cellules ans valeur plutôt que""
tant qu'on ne connaît pas cette origine difficile de dire autre chose
en tout cas la formule pour lundi:
=SOMMEPROD((JOURSEM($B$4:$AF$4;2)=1)*(B5:AF5))


pour les deux formule:
=1 pourlundi, 2 pour mardi etc

crdlmnt


Messages postés
91
Date d'inscription
lundi 23 août 2004
Statut
Membre
Dernière intervention
20 mars 2018

Bonsoir, j'ai fait ce que tu ma dit
Feuille 1 j'ai remplacer le "" par le 0
Je fais dans l'onglet nuit et je tape la formule =SOMMEPROD((JOURSEM($B$4:$AF$4;1)=1)*(B5:AF5))
dans la cellule aj 5 pour les lundi ; sa fonctionne , mais pour le reste de la semaine sa fonctionne pas.
Le mardi il me met (1 mais il n y a pas de mardi sélectionner.
Pour mer,jeu,ven,sam,dim il met nombre ?
dans la cellule an5 j'aimerai qu il ajoute la somme du lundi au jeudi.si tu comprend ce que je raconte .
Merci
https://cjoint.com/c/HCcr2UotoHI
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 053
C'est déjà bien que ça fonctionne pour un jour:-))

pour les autres:

1° ajuster le N° du jour de semaine à chaque colonne =1 pour lundi, 2 pour mardi, 3 pour mercredi jusqu'à 7 si besoin pour dimanche
=SOMMEPROD((JOURSEM($B$4:$AF$4;1)=1)*($B5:$AF5))
ou alors écrivez en AJ5:
=SOMMEPROD((JOURSEM($B$4:$AF$4;1)=COLONNE(A$1))*($B5:$AF5))
qui va s'incrémenter tout seul vers la droite
(en aparté: pour comprendre écrivez par exemple en B24= JOURSEM(B4;2) et tirez vers la droite)

2° vos colonnes de champ à sommer ne sont pas bloquées et se décalent quand vous tirez vers la droite (B devient C AF devient AG etc....

écrivez bien:

=.......($B5:$AF5))

avec les signe $^devant la colonne et pas devant la, ligne pour décaler vers le bas, mais pas vers la droite.

crdlmnt
Messages postés
91
Date d'inscription
lundi 23 août 2004
Statut
Membre
Dernière intervention
20 mars 2018

bonsoir
Tout va très bien sa fonctionne
un très grand merci.
Je te remercie pour ton aide et ta patience
bonne soirée
Josiane
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 053
suite

en réalité, je n'avais pas vu que dans la formule, vous n'aviez pas affecté le bon N° de jour au bon endroit.
Ce n'est pas dans JOURSEM($B$4:$AE$;2) qu'il faut changer le N° mais le 1 après le signe = JOURSEM($B$4:$AF$4;2)=1 ou = 2 ou =3 etc...
voila ce que ça devrait donner:
https://mon-partage.fr/f/hjyosq6e/

crdlmnt
Messages postés
91
Date d'inscription
lundi 23 août 2004
Statut
Membre
Dernière intervention
20 mars 2018

Bonjour et Merci encore
Bonne journée