Formule rechercher pour retrouver donnes

[Résolu/Fermé]
Signaler
Messages postés
89
Date d'inscription
vendredi 7 mars 2008
Statut
Membre
Dernière intervention
15 avril 2018
-
Messages postés
89
Date d'inscription
vendredi 7 mars 2008
Statut
Membre
Dernière intervention
15 avril 2018
-
Bonjour,

https://www.cjoint.com/c/HCbtH3Zdny4

je veux que rechercher des données d un onglet pour les rajouter a la suite de ma feuille de liaison !

Ci_joint mon fichier !

merci de votre aide et reste a votre ecoute

1 réponse

Messages postés
26183
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 septembre 2021
6 052
Bonsoir

vous ne pouvez ressortir que les codes existant à la fois en colonne A de base et en A de liaison, c'est à dire peu..

=RECHERCHEV($A2;List;COLONNE(C$1);0)

à tirer vers la droite

cette formule renvoie #N/A si la réf n'existe pas en base

vous pouvez éviter ça avec
=SIERREUR(RECHERCHEV($A2;List;COLONNE(C$1);0);"))

Notez pour info que dans votre formule de recherche en J2 vous avez noté ...;COLONNE() soit la valeur 10 car cette formulation renvoie le N° de colonne où se trouve la formule, pour avoir un 1 il faut écrire COLONNE(C$1) égal à 3 qui deviendra COLONNE(D$1) vers la droite, égal à 4 etc.

crdlmnt



Messages postés
26183
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 septembre 2021
6 052
... et pour suivre mon message précédent (corrigé) ça dnne ça:
https://mon-partage.fr/f/bE7klaPD/
Messages postés
89
Date d'inscription
vendredi 7 mars 2008
Statut
Membre
Dernière intervention
15 avril 2018

Bonsoir , j 'espère que vous arriverais a mon comprendre ...

mon bute rechercher c est de pouvoir récupéré les prix UT , TTC et catégories de la sélection ou sont stocker c est données de les intégré a ma nouvelle feuille ou tout est liste
et j ai utiliser la fonction sont vraiment savoir ce que je fessais !
même si y a des doublons ou car ma liste répété la même choses mais pour des agent différents .

merci beaucoup de votre temps

cdt
Messages postés
89
Date d'inscription
vendredi 7 mars 2008
Statut
Membre
Dernière intervention
15 avril 2018

je vais tester ça et merci d'avance !
Messages postés
89
Date d'inscription
vendredi 7 mars 2008
Statut
Membre
Dernière intervention
15 avril 2018

je viens de voir , super ....... et logique que s affiche pour pas l'autre fournisseur car j attend leur fichier des tarifs par Email . je vais aller analyser la la formule ... franchement super

merci et bonne soirée a vous .