énigme formules plusieurs conditions plusieurs cas [Résolu/Fermé]

Signaler
-
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
-
Bonjour,
Encore une énigme pour moi et j'espère pas pour vous, voici mon problème :

SI I2="C" ou I2="V" et que H36<3311 alors 0 pour les deux; MAIS SI I2="C"ou I2="V" et que 3311<H36<13244 alors pour C : H36 et pour V : H36*0.7; ENSUITE SI I2="C" ou I2="V" et que H36>13244 alors 13244 pour tout le monde.

bon c'est pas hyper claire sur papier hésitez pas si questions.
Merci


2 réponses

Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Bonsoir

=SI(ET(OU(I2="C";I2="V");H36<3311);0;SI(ET(OU(I2="C";I2="V");H36>3311;H36<13244);H36*SI(I2="V";0,7;1);SI(ET(OU(I2="C";I2="V");H36>13244);13244;"")))

il y aura surement à placer des >= ou<= quelques parts, au cas ou les valeurs de H tombent sur les limites
et cette fois essayez de nous dire si ça fonctionne, je ne crois pas avoir vu de réponse sur les précédentes propositions?

crdlmnt


Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Vu le message sur le fil précédent, c'est OK

Il y a des choses qui coincent (un peu) dans votre demande, c'est traiter la valeur de H36 avec J11, 3311 et 13244. On suppose que la condition si H36<J11 s'applique quelque soit la position de H36 entre 3311 et 13244?
Merci donc de confirmer:
  • le point expliqué ci dessus
  • le fait que dans tous les cas si H36>13244 le résultat cherché est 13244 sinon, c'est H36 si I1 est "C"et H36*0,7 si I1 est V
  • Dire aussi si J11 peut être supérieur à 13244 et si oui, ce qu'il faut faire dans ce cas si H36 est plus petit

et je regarde ça demain matin si personne ne propose quelque chose., je ferme pour ce soir
bonne soirée
crdlmnt
Bonjour,
Je vais essayer d'être plus claire (enfin j'espère) et j'ai simplifié les contraintes :
SI H36<13244 alors H36 pour C
SI H37<13244 alors H37 pour V
SI H36>13244 alors 13244 pour C.
Mais SI H37>13244 alors 13244 pour V.
Voila
Cdt
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
décidemment vous avez du mal à trouver une voie?
on va put être finir par s'en sortir:

=SI(OU(ET(H36>13244;J1="C");ET(H37>13244;J1="V"));13244;SI(ET(H36<=13244;J1="C");H36;SI(ET(H37<=13244;J1="V");H37;"")))

avec un peu de chance, ça devrait aller!

crdlmnt
Bonjour,
Ouais, trop bien ça fonctionne, merci beaucoup.
très Cdt
à la prochaine fois ;)
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Pas de quoi, je passe le sujet en résolu
à la prochaine
bonne route
crdlmnt
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Bonjour
en attendant vos précisions (message précédent), voyez ce modèle
l'ordre des conditions (surtout la dernière) sera peut être à modifier selon ce qui se passe en H36
(par exemple si H36 >13244 mais <J11, la formule appliquera la 1° condition)
à affiner donc
https://mon-partage.fr/f/paCHa5pC/
crdlmnt

Bonjour,
Reformulation de formule dans commentaire précédent.
Cdt