Formule pour calculer le nombre de mois et année [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
9 février 2018
-
Messages postés
25426
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2020
-
Bonjour,
Dans une colonne plusieurs date ( mois et année) et je voudrais savoir combien y a mois (janvier et année )
mars2018 =1 / sep 2017 =3 oct2017 =4
mars/2018
sept/2017
sept/2017
sept/2017
oct/2017
oct/2017
oct/2017
oct/2017

Je vous remercie
RGUY1


4 réponses

Messages postés
52484
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2020
14 359
Bonjour.

Solution N°1 :
Les dates étant saisies de A1 à A8,
saisir 1 en B1,
la formule =NB.SI(A$1:A2;A2) en B2
à recopier jusqu'en B8.
Messages postés
25426
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2020
5 549
Bonjour
variante au cas où les dates ne soient pas toutes alignées sur le même jour, et donc inégales:

à adapter
=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(A2))*1)

éventuellement pour faire un tableau, formule pour janvier:

=SOMMEPROD((MOIS($A$2:$A$100)=1)*1)

et si besoin, pour tirer la formule sur la hauteur et n'afficher que sur la 1° ligne où se trouve le mois:

=SI(SOMMEPROD((MOIS($A$2:A2)=MOIS(A2))*1)>1;"";SOMMEPROD((MOIS($A$2:$A$100)=MOIS(A2))*1)



attention à la position des signes $

SOMMEPROD étant assez lourde, limitez les champs au nombre de lignes utiles (ici de 2à100)

crdlmnt
Messages postés
4
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
9 février 2018

salut merci pour vos réponses mais
Je voudrai savoir combien y a de film par mois, sans les comptés manuellement
Le fichier a 960 lignes, Date sur la colonne F
A B C D E F
A BLUE Science Fiction 02:00 10-mai-2017 juin/2002 6
B BLUE Science Fiction 01:35 10janv.-2008 anv/2008 7
C BLUE Science Fiction 02:20 19-juin-2002 août/2008 1
D BLUE Science Fiction 01:55 23-mars-2016 mars/2016 6
E BLUE Science Fiction 01:45 10-mai-2017 mai/2017 2
F BLUE Science Fiction 01:35 1-janv.-2008
G BLUE Historique 03:00 23-mars-2016
G BLUE Fantastique 01:55 23-mars-2016
H BLUE Aventure 02:10 1-janv.-2008
I BLUE Aventure 02:30 19-juin-2002
J BLUE Science Fiction 02:05 09-juin-2002
J BLUE Fantastique 01:55 19-juin-2002
K BLUE Science Fiction 02:05 1-janv.-2008
L BLUE Science Fiction 02:00 19-juin-2002
L BLUE Science Fiction 02:05 10-mai-2017
L BLUE Science Fiction 02:45 1-oct.-2017
N BLUE Science Fiction 02:20 19-juin-2002
O BLUE Science Fiction 02:30 1-janv.-2008
P BLUE Science Fiction 02:45 23-mars-2016
Q BLUE Fantastique 02:30 23-mars-2016
R BLUE Science Fiction 02:10 1-janv.-2008
R BLUE Fantastique 01:45 23-mars-2016
S BLUE Historique 03:40 1-janv.-2008
S BLUE Science Fiction 01:55 10-mai-2017
MERCI ENCOR CORDIALEMENT RGUY1
Messages postés
25426
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2020
5 549
Re

si vous voulez compter le nombre de date en F dans le mois, c'est la formule que je vous ai proposée qui devrait faire l'affaire
par exemplepar mois:
faites une liste de N° de 1à12 en H2:H13 par exemple
en I2
=SOMMEPROD((MOIS($F$1:$F$1000)=H2)*1)
à tier sur la hauteur
cette formule va mélanger les années

vous pouvez les indentifer aussi comme suit:

votre liste de 1à12 en H
de I1 à Z1 ou autre si besoin la liste des années
la formule en I2:

=SOMMEPROD((ANNEE($F$1:$F$1000)=I$1)*(MOIS($F$1:$F1000)=$H2))

respectez bien les positions des $ pour tirer la formule sur tout le tableau

ajuster les champs à votre nombre de lignes

et vous pourrez ajouter en G:=SOMME(I2:Z2) pour avoir le total par mois

crdlmnt
Messages postés
4
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
9 février 2018

merci
je ne suis pas tres for avec excel, mais je vais chercher avec cette formule,
parfois j ai un résulta et parfois pas.
merci encore
Cordialement rguy1
Messages postés
25426
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2020
5 549
bonjour
pour les résultats aléatoires, surveiller bien
vos écritures, la conformité des formats dates, des entées clavier entre les titres du tableau et la base de données
le respect des positions des signes $ qui bloquent les références des formules(tout, colonne ou ligne)
crdlmnt
Messages postés
4
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
9 février 2018

Merci
rguy1
Messages postés
25426
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2020
5 549
pas de quoi, si cela convient, merci de passer le sujet en résolu (menu roue dentée sous le titre du fil)
bonne route
crdlmnt
Messages postés
52484
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2020
14 359
Tu fais un filtre sur la colonne.
Le nombre d'occurrences s'affiche dans la barre d'état, en bas à gauche.