Install MySQL, echec démarrage du service

Résolu/Fermé
Signaler
-
 medarkness -
Bonjour,
j'ai un problème avec mon installation mysql qui ne veut pas se lancer. Je l'ai config, make et make install, aucun souci mais lorsque que je veux lancer le service avec /usr/local/mysql4/bin/mysql start, j'ai un message d'erreur avec mysql.sock : can't connect to local MySQL Server through socket /usr/local/mysql4/share/mysql.sock (111)
au début j'ai cru que c'était une affaire de droits, alors j'ai donné le bons droits au groupe mysql sur mon dossier /usr/local/mysql4 (et les dossiers enfants). Mais j'ai toujours cette erreur !
D'ou vient le problème svp ?

Merci d'avance...

7 réponses

Fedora 7
voila ma démarche :
./configure --prefix=/usr/local/mysql4 --localstatedir=/donnees/mysql4 --enable-assembler
make
make install
avec le dernier package MySQL 4.1.22

etc/my.cnf
# Example MySQL config file for large systems.
#
# This is for a large system with memory = 512M where the system runs mainly
# MySQL.
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /donnees/mysql4) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password	= your_password
port		= 3306
socket		= /usr/local/mysql4/share/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port		= 3306
socket		= /usr/local/mysql4/share/mysql.sock
skip-locking
key_buffer = 256M
max_allowed_packet = 1M
table_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
read_rnd_buffer_size = 4M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size= 16M
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 8

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
# 
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
log-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id	= 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin

# Point the following paths to different dedicated disks
#tmpdir		= /tmp/		
#log-update 	= /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 64M
#bdb_max_lock = 100000

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /donnees/mysql4/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /donnees/mysql4/
#innodb_log_arch_dir = /donnees/mysql4/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 256M
#innodb_additional_mem_pool_size = 20M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 64M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout



j'ai modifié les droits sur /donnees/mysql4 et /usr/local/mysql4 (chgrp -R mysql <chemin>)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 562
Salut,

tu as quoi comme distribution?
quel tutoriel tu as suis pour l'installation?
affiche le contenu de my.cnf (c'est le fichier de configuration de mysql)
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 562
je veux lancer le service avec /usr/local/mysql4/bin/mysql start

pourqoui tu démarres le serveur de cette manière?

essaie de decommenter cette ligne
#tmpdir = /tmp/

donc enleve le #
tmpdir		= /tmp/		
à l'époque j'avais aussi une erreur de ce genre
mysql installation depuis les sources
C'est bon je te remercie
Bonjour,

J'ai le meme problème avec mon installation mysql qui ne veut pas se lancer.
Avec la commande: mysql /usr/local/mysql/bin/mysqld Mysql ne se lance pas! Et j'ai la meme erreur en faisant mysql start

J'ai un message d'erreur avec mysql.sock : can't connect to local MySQL Server through socket 'tmp/mysql.
sock' (2)

J'ai installe mysql-standard-4.1.21-pc-linux-gnu-i686-glibc23.tar.gz

Dans le fichier etc/my.cnf, j'ai decommente la ligne
#tmpdir = /tmp/

Mais j'ai toujours la meme erreur

D'ou vient le problème svp ?

Merci d'avance pour votre aide ...

Configuration: Linux
Distribution: Cemtos 5.1 avec Apache 2.2.3 et PHP 5.2.5
Bonjour,

J'ai le meme problème avec mon installation mysql qui ne veut pas se lancer.
Avec la commande: mysql /usr/local/mysql/bin/mysqld Mysql ne se lance pas! Et j'ai la meme erreur en faisant mysql start

J'ai un message d'erreur avec mysql.sock : can't connect to local MySQL Server through socket 'tmp/mysql.
sock' (2)

J'ai installe mysql-standard-4.1.21-pc-linux-gnu-i686-glibc23.tar.gz

Dans le fichier etc/my.cnf, j'ai decommente la ligne
#tmpdir = /tmp/

Mais j'ai toujours la meme erreur

D'ou vient le problème svp ?

Merci d'avance pour votre aide ...

Configuration: Linux
Distribution: Cemtos 5.1 avec Apache 2.2.3 et PHP 5.2.5
faut toujours précéder sa commande mysql par ./mysql start ./mysql restart avant faut se mettre dans le dossier /etc/mysql/
normalement ca va marcher
peace