Pb prestashop et migration en local

Fermé
Signaler
-
Messages postés
28792
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
23 octobre 2021
-
Bonjour,

J'ai un problème de migration en local sur wampserver d'un presta 1.7.2.4

Je me retrouve avec une HTTP ERROR 500

J'ai fermé le presta

Importé la base et les fichiers

Mis tout ça en place dans wampserver

Le dossier cache est vide, la config de liaison à la base à été changé et j'ai mis à jour l'url directement dans shop_url

Je sèche, quelqu'un a une idée ?

Merci d'avance



5 réponses

Messages postés
166
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
30 octobre 2021
34
Bonjour,

Supprimer le htaccess.
Je l'ai fait bien sur vu que c'est la principale source des erreurs 500 mais ça n'a rien changé.
Messages postés
28792
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
23 octobre 2021
9 751
Bonjour,

En général, quand une erreur 500 se produit, il y a des traces dans les logs du serveur web... commence peut-être déjà, par fouiller dans les logs ?

ça devrait être le 1er reflex en cas de problème...
Bonjour ;)

J'ai regardé aussi mais j'ai rien trouvé ou je n'ai pas su l'interpreter.

j'ai essayé d’accéder là pour sortir un log. Y a rien dans le log apache et y a ça dans le log php :

[08-Dec-2017 22:42:42 UTC] PHP Stack trace:
[08-Dec-2017 22:42:42 UTC] PHP 1. {main}() D:\wamp64\www\allmysnkrs\index.php:0
[08-Dec-2017 22:42:42 UTC] PHP 2. require() D:\wamp64\www\allmysnkrs\index.php:27
[08-Dec-2017 22:42:42 UTC] PHP 3. require_once() D:\wamp64\www\allmysnkrs\config\config.inc.php:34
[08-Dec-2017 22:42:42 UTC] PHP 4. require() D:\wamp64\www\allmysnkrs\config\autoload.php:33
[08-Dec-2017 22:42:42 UTC] PHP 5. require() D:\wamp64\www\allmysnkrs\app\autoload.php:34
[08-Dec-2017 22:42:42 UTC] PHP 6. composerAutoloaderInit496f07af0d0ed8ade754e94f238e54cb::getLoader() D:\wamp64\www\allmysnkrs\vendor\autoload.php:7
[08-Dec-2017 22:42:42 UTC] PHP 7. composerRequire496f07af0d0ed8ade754e94f238e54cb() D:\wamp64\www\allmysnkrs\vendor\composer\autoload_real.php:60

et ça dans le log access :

[08/Dec/2017:22:42:42 +0100] "GET /allmysnkrs/ HTTP/1.1" 500 -
Messages postés
28792
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
23 octobre 2021
9 751
Dans le log PHP, il y a une partie, mais avant ça, tu dois probablement avoir d'autre choses... non ?

Sinon, il manque de la verbosité probablement, pour les logs apache... à voir. Mais, tel que c'est là, difficile de savoir d'où vient le souci, si aucune erreur.

Au besoin, dans un .htaccess, ajouter ça :

php_flag display_errors on
php_flag html_errors on
php_flag log_errors on


ça forcera l'activation des logs, si ils ne sont pas activés.
Apache :

[Sat Dec 09 10:16:58.704470 2017] [mpm_winnt:notice] [pid 7036:tid 756] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sat Dec 09 10:17:00.707161 2017] [mpm_winnt:notice] [pid 9832:tid 708] AH00364: Child: All worker threads have exited.
[Sat Dec 09 10:17:00.802994 2017] [mpm_winnt:notice] [pid 7036:tid 756] AH00430: Parent: Child process 9832 exited successfully.
[Sat Dec 09 10:17:02.062509 2017] [mpm_winnt:notice] [pid 1604:tid 748] AH00455: Apache/2.4.27 (Win64) PHP/5.6.31 configured -- resuming normal operations
[Sat Dec 09 10:17:02.062509 2017] [mpm_winnt:notice] [pid 1604:tid 748] AH00456: Apache Lounge VC15 Server built: Jul 7 2017 12:46:00
[Sat Dec 09 10:17:02.062509 2017] [core:notice] [pid 1604:tid 748] AH00094: Command line: 'D:\\wamp64\\bin\\apache\\apache2.4.27\\bin\\httpd.exe -d D:/wamp64/bin/apache/apache2.4.27'
[Sat Dec 09 10:17:02.078527 2017] [mpm_winnt:notice] [pid 1604:tid 748] AH00418: Parent: Created child process 16368
[Sat Dec 09 10:17:02.387442 2017] [mpm_winnt:notice] [pid 16368:tid 740] AH00354: Child: Starting 64 worker threads.
[Sat Dec 09 10:17:16.429146 2017] [mpm_winnt:notice] [pid 1604:tid 748] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sat Dec 09 10:17:18.434180 2017] [mpm_winnt:notice] [pid 16368:tid 740] AH00364: Child: All worker threads have exited.
[Sat Dec 09 10:17:18.463325 2017] [mpm_winnt:notice] [pid 1604:tid 748] AH00430: Parent: Child process 16368 exited successfully.
[Sat Dec 09 10:17:28.986188 2017] [mpm_winnt:notice] [pid 16808:tid 516] AH00455: Apache/2.4.27 (Win64) PHP/5.6.31 configured -- resuming normal operations
[Sat Dec 09 10:17:28.986188 2017] [mpm_winnt:notice] [pid 16808:tid 516] AH00456: Apache Lounge VC15 Server built: Jul 7 2017 12:46:00
[Sat Dec 09 10:17:28.986188 2017] [core:notice] [pid 16808:tid 516] AH00094: Command line: 'D:\\wamp64\\bin\\apache\\apache2.4.27\\bin\\httpd.exe -d D:/wamp64/bin/apache/apache2.4.27'
[Sat Dec 09 10:17:29.001220 2017] [mpm_winnt:notice] [pid 16808:tid 516] AH00418: Parent: Created child process 16868
[Sat Dec 09 10:17:29.378494 2017] [mpm_winnt:notice] [pid 16868:tid 736] AH00354: Child: Starting 64 worker threads.

[09-Dec-2017 09:21:02 UTC] PHP Warning: require(D:\wamp64\www\allmysnkrs\vendor\composer/../react/promise/src/functions_include.php): failed to open stream: No such file or directory in D:\wamp64\www\allmysnkrs\vendor\composer\autoload_real.php on line 70

[09-Dec-2017 09:21:03 UTC] PHP Stack trace:

[09-Dec-2017 09:21:03 UTC] PHP 1. {main}() D:\wamp64\www\allmysnkrs\index.php:0

[09-Dec-2017 09:21:03 UTC] PHP 2. require() D:\wamp64\www\allmysnkrs\index.php:27

[09-Dec-2017 09:21:03 UTC] PHP 3. require_once() D:\wamp64\www\allmysnkrs\config\config.inc.php:34

[09-Dec-2017 09:21:03 UTC] PHP 4. require() D:\wamp64\www\allmysnkrs\config\autoload.php:33

[09-Dec-2017 09:21:03 UTC] PHP 5. require() D:\wamp64\www\allmysnkrs\app\autoload.php:34

[09-Dec-2017 09:21:03 UTC] PHP 6. ComposerAutoloaderInit496f07af0d0ed8ade754e94f238e54cb::getLoader() D:\wamp64\www\allmysnkrs\vendor\autoload.php:7

[09-Dec-2017 09:21:03 UTC] PHP 7. composerRequire496f07af0d0ed8ade754e94f238e54cb() D:\wamp64\www\allmysnkrs\vendor\composer\autoload_real.php:60

[09-Dec-2017 09:21:03 UTC] PHP Fatal error: require(): Failed opening required 'D:\wamp64\www\allmysnkrs\vendor\composer/../react/promise/src/functions_include.php' (include_path='D:\wamp64\www\allmysnkrs\vendor/pear/pear_exception;D:\wamp64\www\allmysnkrs\vendor/pear/console_getopt;D:\wamp64\www\allmysnkrs\vendor/pear/pear-core-minimal/src;D:\wamp64\www\allmysnkrs\vendor/pear/archive_tar;.;C:\php\pear') in D:\wamp64\www\allmysnkrs\vendor\composer\autoload_real.php on line 70

[09-Dec-2017 09:21:03 UTC] PHP Stack trace:

[09-Dec-2017 09:21:03 UTC] PHP 1. {main}() D:\wamp64\www\allmysnkrs\index.php:0

[09-Dec-2017 09:21:03 UTC] PHP 2. require() D:\wamp64\www\allmysnkrs\index.php:27

[09-Dec-2017 09:21:03 UTC] PHP 3. require_once() D:\wamp64\www\allmysnkrs\config\config.inc.php:34

[09-Dec-2017 09:21:03 UTC] PHP 4. require() D:\wamp64\www\allmysnkrs\config\autoload.php:33

[09-Dec-2017 09:21:03 UTC] PHP 5. require() D:\wamp64\www\allmysnkrs\app\autoload.php:34

[09-Dec-2017 09:21:03 UTC] PHP 6. ComposerAutoloaderInit496f07af0d0ed8ade754e94f238e54cb::getLoader() D:\wamp64\www\allmysnkrs\vendor\autoload.php:7

[09-Dec-2017 09:21:03 UTC] PHP 7. composerRequire496f07af0d0ed8ade754e94f238e54cb() D:\wamp64\www\allmysnkrs\vendor\composer\autoload_real.php:60
Messages postés
166
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
30 octobre 2021
34
Pour ps 1.7 dans wampserver,
-Aller dans php.ini
-Chercher "opcache.enable=0" et "opcache.enable_cli=0"
Remplacer les valeurs "0" par "1"
-Chercher "realpath_cache_size"
Mettre la valeur à 5M et supprimer ";"
-Redémarrer les services de wampserver

Si le problème persiste, Telecharger ps 1.7 et faire une nouvelle installation.
S'il reste des erreurs à corriger dans wampserver, elles seront affichées à l'étape 2 de l'installation.
Merci j'ai effectué les réglages et je n'ai pas de mention à l'étape 2 de l'install.
Par contre ça n'a pas réglé mon erreur 500 sur le presta que je veux importer dans wamp.
Messages postés
28792
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
23 octobre 2021
9 751 > Nimacori
Dans le logs au dessus, tu as une erreur fatal en PHP, qui semble ne pas savoir importer quelque chose. :-)

Reste plus qu'à vérifier ce qui est concerné.
ça ?

09-Dec-2017 09:21:02 UTC] PHP Warning: require(D:\wamp64\www\allmysnkrs\vendor\composer/../react/promise/src/functions_include.php): failed to open stream: No such file or directory in D:\wamp64\www\allmysnkrs\vendor\composer\autoload_real.php on line 70
Messages postés
28792
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
23 octobre 2021
9 751 > Nimacori
Là, plutôt :

[09-Dec-2017 09:21:03 UTC] PHP Fatal error: require(): Failed opening required 'D:\wamp64\www\allmysnkrs\vendor\composer/../react/promise/src/functions_include.php' (include_path='D:\wamp64\www\allmysnkrs\vendor/pear/pear_exception;D:\wamp64\www\allmysnkrs\vendor/pear/console_getopt;D:\wamp64\www\allmysnkrs\vendor/pear/pear-core-minimal/src;D:\wamp64\www\allmysnkrs\vendor/pear/archive_tar;.;C:\php\pear') in D:\wamp64\www\allmysnkrs\vendor\composer\autoload_real.php on line 70