Données non autorisées dynamique Excel 2010 [Résolu/Fermé]

Signaler
Messages postés
147
Date d'inscription
dimanche 16 octobre 2016
Statut
Membre
Dernière intervention
27 juillet 2018
-
Messages postés
147
Date d'inscription
dimanche 16 octobre 2016
Statut
Membre
Dernière intervention
27 juillet 2018
-
Bonjour, serait-il possible de regrouper des données non autorisées et les rendre dynamique et évolutive? https://www.cjoint.com/c/GIvsVHCHJNP
Par avance, je vous remercie de votre aide. Cordialement, Zizou

4 réponses

Messages postés
12938
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 mars 2021
2 137
Bonjour

En B2 :
=NB.SI.ENS(Données!$B$2:$B28;A2;Données!$C$2:$C28;">="&Résultat!$E$3;Données!$C$2:$C28;"<="&Résultat!$F$3;Données!$A$2:$A28;Résultat!$H$3;Données!$D$2:$D28;Résultat!$G$3)
à étirer jusqu’en B5

En B6 :
=NB.SI.ENS(Données!$C$2:$C32;">="&Résultat!$E$3;Données!$C$2:$C32;"<="&Résultat!$F$3;Données!$A$2:$A32;Résultat!$H$3;Données!$D$2:$D32;Résultat!$G$3)-SOMME(B2:B5)

Cdlmnt
Via

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
12938
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 mars 2021
2 137
Bonjour

Avec plaisir :
=NB.SI.ENS(Données!$B$2:$B28;A2;Données!$C$2:$C28;">="&Résultat!$E$3;Données!$C$2:$C28;"<="&Résultat!$F$3;Données!$A$2:$A28;Résultat!$H$3;Données!$D$2:$D28;Résultat!$G$3)
On dénombre avec les conditions :
En B même valeur que A (le texte autorisé)
En C valeur supérieure ou égale à E et inférieure ou égale à F (toute valeur dans l'intervalle E-F donc) (les mois)
En A même valeur que H3 (l'arrondissement)
En D même valeur que G3 l'année)

Pour la formule qui doit donner le nombre d'autres valeurs on dénombre toutes les valeurs quel qu’elles soient dans l’intervalle de mois, de l'arrondissement et de l'année (dénombre donc toute sles valeurs autorisées et non autorisées) puis on enlève du résultat la somme des résultats précédents (valeurs autorisées) pour obtenir le nombre de valeurs non autorisées

Cdlmnt
Via
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
147
Date d'inscription
dimanche 16 octobre 2016
Statut
Membre
Dernière intervention
27 juillet 2018
15
Bonjour VIA, franchement trop fort ça fonctionne à merveille.Aurais-tu l'amabilité de détailler la formule (hors liste)? J’essaie de la comprendre. Encore merci de ton aide. Cordialement, Zizou
Messages postés
147
Date d'inscription
dimanche 16 octobre 2016
Statut
Membre
Dernière intervention
27 juillet 2018
15
Je te remercie pour toute ces explications et de ton aide, c'est vraiment cool de partager sa connaissance. Je te souhaite une excellente nuit. Cordialement, Zizou