Fonction Si avec *

Résolu/Fermé
christ.lenoir Messages postés 38 Date d'inscription mardi 6 juin 2017 Statut Membre Dernière intervention 7 septembre 2017 - 1 sept. 2017 à 18:03
 victor - 1 sept. 2017 à 18:49
Bonjour,

Je tente de faire une fonction Si toute simple qui ne marche pas en raison de l'*.
J'explique : Pour la colonne G, j'ai plusieurs phrases différentes, quelques unes qui commence par un * et d'autre qui commence par rien du tout.
Exemple: Je mange une pomme ou bien : * Je mange une banane.
Dans ce cas-ci, mon je veux avoir seulement ceux dont la phrase ne commence pas par *.
Ma fonction Si est donc :
=SI(G5="* ";0;I5)

Toutefois, je sais que dans Excel le symbole * signifie de prendre peu importe ce qu'il y a après ... alors ma fonction ne marche pas puisqu'elle n'isole pas ceux commençant par *.

Je ne peux pas changer mes phrases ou symboles ...

Y'a t'il un moyen de contourner ce problème? Je peux utiliser le VBA si nécessaire.

Merci d'avance

3 réponses

via55 Messages postés 14445 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 18 juillet 2024 2 721
1 sept. 2017 à 18:09
Bonjour

Essaie :
=SI(GAUCHE(G5;1)="*";0;I5)


Cdlmnt
Via
christ.lenoir Messages postés 38 Date d'inscription mardi 6 juin 2017 Statut Membre Dernière intervention 7 septembre 2017
1 sept. 2017 à 18:33
Wow merci ça fonctionne :)
0
yg_be Messages postés 22998 Date d'inscription lundi 9 juin 2008 Statut Contributeur Dernière intervention 20 juillet 2024 1 496
1 sept. 2017 à 18:10
bonjour, moi j'essaierais:
=SI(gauche(G5;2)="* ";0;I5)
Raymond PENTIER Messages postés 58544 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 19 juillet 2024 17 148
1 sept. 2017 à 18:24
Résultat identique ...
0
victor > Raymond PENTIER Messages postés 58544 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 19 juillet 2024
1 sept. 2017 à 18:39
Non, c'est une sécurité pour un texte commençant par une étoile et un espace
=> un texte qui commence par une étoile sans un espace juste après ne sera
pas concerné.
0
Raymond PENTIER Messages postés 58544 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 19 juillet 2024 17 148 > victor
1 sept. 2017 à 18:41
et si le texte commence par une étoile et 2 espaces ?
0
victor > Raymond PENTIER Messages postés 58544 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 19 juillet 2024
1 sept. 2017 à 18:49
La même formule marchera aussi bien : pour un texte commençant par une étoile
et un ou plusieurs espace(s), le «* » du début sera détecté de la même façon =>
ça fait toujours une distinction avec un texte commençant par une étoile sans
espace après.  ;)
0
christ.lenoir Messages postés 38 Date d'inscription mardi 6 juin 2017 Statut Membre Dernière intervention 7 septembre 2017
1 sept. 2017 à 18:33
Merci :)
0
Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 mars 2023 1 778
1 sept. 2017 à 18:32
Bonjour,

Peut-être bien :
=SI(GAUCHE(G5;2)="* ";"";G5)