Recherche sur plusieurs colonnes

Résolu/Fermé
zara70 Messages postés 178 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 4 juin 2022 - 28 juil. 2017 à 10:34
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 28 juil. 2017 à 12:28
Bonjour,

Je souhaite vérifier si les données connues dans une colonne (A par exemple), sont aussi présentes en colonne B, C et D.

Et si oui pouvoir faire apparaitre en résultat de ma formule une codification spécifique.

Je m'explique :

La colonne A comporte l'intégralité des n° de clients connus en B, C et D
La colonne B comporte des n° de clients ayant achetés des crèmes de beauté
La colonne C comporte des n° de clients ayant achetés des shampooings
La colonne D comporte des n° de clients ayant achetés du maquillage

Je souhaite créer une formule qui me permette de dire rapidement si le client en A2, est aussi connus en B, C et D, et en fonction qu'on me rapporte le nbre de colonne dans laquelle ce même n° est connu (1,2 ou 3).

Pensez vous que cela soit envisageable et comment ?

Merci beaucoup à vous, je sais que je peux compter sur vous.

Zara70

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
28 juil. 2017 à 10:47
Bonjour

on suppose:
que dans chaque colonne le N° de client peut se trouver sur des lignes différentes
que le N° de client peut apparaître plusieurs fois dans la même colonne
avec cette formule en E2, donc:

=SI(NB.SI(B:B;A2);1;0)+SI(NB.SI(C:C;A2);1;0)+SI(NB.SI(D:D;A2);1;0)



mais si vous placez les achats clients avec le code en A cette simple formule suffit:
=NB.SI(B2:A2;A2)

crdlmnt
0
zara70 Messages postés 178 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 4 juin 2022 1
28 juil. 2017 à 11:10
C'est super, j'ai mon résultat, merci beaucoup.

J'ai utilisé la 1ère solution. Pensez-vous qu'il soit possible de préciser dans le résultat de la formule que si le résultat est 1 (c'est à dire que le n° de client a été trouvé une fois dans les 3 colonnes), qu'il me soit précisé en plus (voir par une formule dans une nouvelle colonne) dans quelle colonne il a été trouvé. Même chose si il a été trouvé dans 2 colonnes, que la formule me précise lesquelles.

Peut-être est ce compliqué, voir impossible à faire ....
Qu'en pensez vous avec votre expertise ?

Cordialement,

Zara70
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
Modifié le 28 juil. 2017 à 12:29
pas sur d'avoir
essayez cette formule en E2, en supposant que sur une ligne 1 en B C D vous avez les titres de colonnes:

=SI(NB.SI(B:B;A2);" / "&$B$1;"")&SI(NB.SI(C:C;A2);" / "&$C$1;"")&SI(NB.SI(D:D;A2);" / "&$D$1;"")

crdlmnt
0
zara70 Messages postés 178 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 4 juin 2022 1
28 juil. 2017 à 12:27
C'est PARFAIT pour moi. Vous avez complètement répondu à ma demande.

Encore merci

Zara70
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273 > zara70 Messages postés 178 Date d'inscription lundi 29 décembre 2014 Statut Membre Dernière intervention 4 juin 2022
Modifié le 28 juil. 2017 à 12:29
Pas de quoi
je passe le sujet en résolu
bonne route (à la prochaine:-))
crdlmnt
0