XEN - Connexion VM Windows [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mercredi 26 juillet 2017
Statut
Membre
Dernière intervention
26 juillet 2017
-
Messages postés
2
Date d'inscription
mercredi 26 juillet 2017
Statut
Membre
Dernière intervention
26 juillet 2017
-
Bonsoir à tous.

J'ai un serveur de VM sous Xen (debian).
Je ne peux pas mettre à jour ou modifier la configuration de ce serveur pour résoudre mon problème car j'ai des serveurs trop critiques.

Je n'arrive plus à me connecter à une VM Windows en RDP car d'après mes alertes SNMP j'ai la swap à 99 %...
Je sais exactement quel processus pose problème, mais je ne peux pas l'arrêter car je ne peux plus me connecter...

Sur mes autres serveur de VM sous Xen, je peux me connecter en VNC avec l'ip du serveur vm : port correspondant à la VM (ex : 5901).
Mais sur ce serveur là, cela ne fonctionne pas.

Apparemment je peux me connecter dessus sur le port 80.
Sauf que quand j'essaye, ça me met "HTTP ERROR 501" après l'authentification au niveau du navigateur.

Bref, tout ce que je voudrait c'est pouvoir me connecter à cette VM sans devoir la rebooter.

Merci d'avance pour votre aide !


Voir image ci-dessous pour les liens
https://img-19.ccm2.net/tWAfQjktmkrKKLp4D6WA8dPfeAg=/f1da1e364ffa4caeb2b52411e975c7ae/ccm-ugc/646146Capture.jpg

1 réponse

Messages postés
2
Date d'inscription
mercredi 26 juillet 2017
Statut
Membre
Dernière intervention
26 juillet 2017

Le serveur VNC écoute que sur localhost et pas sur 0.0.0.0.
J'ai trouvé une solution je pense : Faire un tunnel SSH.
En Putty je mets l'adresse "serveurXen:5901" et dans Tunnels je mets en source port 5901 et en destination "serveurXen:5901".
Je m'identifie en root, puis je lance un VNC sur "127.0.0.1:5901"

Seul problème, la connexion ne s'établie pas sur VNC : "you've forgotten to select a DSMPlugin and the Server uses a DSMPlugin"

Quelqu'un a une idée ?

Merci d'avance !