Comment associer une valeur à un nom dans excel ? [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mercredi 12 juillet 2017
Statut
Membre
Dernière intervention
13 juillet 2017
-
Messages postés
3
Date d'inscription
mercredi 12 juillet 2017
Statut
Membre
Dernière intervention
13 juillet 2017
-
Bonjour, Afin de calculer des frais de déplacement, j'ai relevé une liste de villes et les kilométrages associés. Comment afficher automatiquement le kilométrage dans la colonne B lorsque je choisis une ville dans la liste déroulante colonne A ? Merci pour votre aide.

1 réponse

Messages postés
25946
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 avril 2021
5 863
Bonjour

votre base de données en feuil1:

_ville en A, distance en B
_édition en feuil2

si on commence en A2
menu déroulant nom de ville en A
km à ressortir en B

=SIERREUR(RECHERCHEV(A2;Feuil1!A:B;2;0);"")

le code si erreur évite l'affichage de #N/A quand A2 est vide, mais n'est applicable qu'à partir de Excel 2007

si antérieur:

=SI(A2="";"";RECHERCHEV(A2;Feuil1!A:B;2;0))

crdlmnt

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
mercredi 12 juillet 2017
Statut
Membre
Dernière intervention
13 juillet 2017

Merci, beaucoup, ça fonctionne ! (J'abuse : Pouvez-vous m'expliquer le "2" et le "0" ?) Très cordialement.
Messages postés
25946
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 avril 2021
5 863 >
Messages postés
3
Date d'inscription
mercredi 12 juillet 2017
Statut
Membre
Dernière intervention
13 juillet 2017

Pas de problème

le 2
RECHERCHEV cherche une valeur dans la 1° colonne d'une plage et ressort celle sur la même ligne dans la,colonne indiqué par le 2
si par exemple vous avez une plage B:X, la formule va chercher la valeur dans la, colonne B et si vous indiquez 2, ressort la valeur en C(2° colonne de B:X) 4 la valeur en D etc...
le 0
c'est un code Excel qui demande à la formule de ne trouver que des valeurs exactes. Cela peut s'écrire aussi....;FAUX)
sans cette info, RECHERCHEV va sélectionner la valeur inférieure la plus proche, à condition que la colonne de recherche soit classée par ordre croissant (Alpha ou num)

et ppur complèter l'info: RECHERCHEH faitb la même chose, mais avec les lignes.

crdlmnt
Messages postés
3
Date d'inscription
mercredi 12 juillet 2017
Statut
Membre
Dernière intervention
13 juillet 2017
>
Messages postés
25946
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 avril 2021

MERCI++++ c'est lumineux !
Cela donne bcp de possibilités et va m'être très utile.

Bonne journée.