Renvoyer une cellule d'un autre onglet si ces cond. vérifiées [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
lundi 26 juin 2017
Statut
Membre
Dernière intervention
29 juin 2017
-
Messages postés
3
Date d'inscription
lundi 26 juin 2017
Statut
Membre
Dernière intervention
29 juin 2017
-
Bonjour !

Plus précisément :
  • Si le contenu de la cellule A3 (de la feuill1) se retrouve en B37 de la feuill2, alors je souhaite que C3 (en feuill1) prenne la valeur de E37 (de la feuill2)
  • Si le contenu de la cellule A9 (de la feuill1) se retrouve en B28 (feuille2), C9 (feuill1) doit prendre la valeur de E28 (feuille2).
  • Si le contenu d'une cellule donnée de la colonne A (de ligne X) et feuille1 se retrouve dans une colonne B de feuille2 en ligne y je souhaite que C de ligne X en feuille1 prenne la valeur de la cellule E ligne Y.
  • Si cette cellule de A n'a pas de correspondance, mettre "Non déterminé"


J'ai appliqué cette formule en C1: =SI(NB.SI(A1;Feuille2!B:B)>0;RECHERCHEV(Feuill2!E:E;5;0);"Non déterminé")

ça me met du "Non déterminé" sur toute la colonne C (de la feuill1) alors qu'il y a bel et bien des correspondances !
Merci d'avance.

2 réponses

Messages postés
12796
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
30 octobre 2020
2 050
Bonjour Adrien

Essaie plutôt en C1 une formule du style :
=SIERREUR(INDEX(Feuil2!E:E;EQUIV(A1;Feuil2!B:B;0));"Non déterminé")
à étirer ensuite vers le bas

Cdlmnt
Via
Messages postés
3
Date d'inscription
lundi 26 juin 2017
Statut
Membre
Dernière intervention
29 juin 2017

Bonjour via55, cela marche très bien, merci beaucoup.
Messages postés
25462
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
5 565
Bonjour
êtes vous sur de ce que vous avez écrit ci dessus dans le code RECHERCHEV, il manque pas mal d'informations et en prime, le NB.SI est apparemment écrit à l'envers:

RECHERCHEV(valeur cherchée;champ;rang de la colonne à ressortir dans le champ;0)

or là, vous n'avez pas de valeur cherchée avec feuill2!E:E
ou alors vous n'avez qu'un champ de une colonne dont il va être difficile de ressortir la 5°

je verrais bien, pour une valeur en A1:

=SI(NB.SI(Feuil2!B:B;A1);RECHERCHEV(A1;Feuil2:B:E;4;0);"non déterminés")

ou plus simplement si vous avez un Excel d'au moins 2007

=SIERREUR(RECHERCHEV(A1;Feuil2:B:E;4;0);"non déterminés")

crdlmnt


Messages postés
3
Date d'inscription
lundi 26 juin 2017
Statut
Membre
Dernière intervention
29 juin 2017

Bonjour Vaucluse, Cela marche bien également, merci beaucoup !