Somme en fonction de période [Résolu/Fermé]

Signaler
-
 Eth6 -
Bonjour à tous,
J'ai un tableau basiquement avec des date en colonne A (ex. 01/01/2014) et des montants en colonne B (ex. 120€).
Je souhaite simplement pour chaque mois faire le total des montants.
Il faudrait donc utiliser les fonctions somme.si ou somme.si.ens mais je n'arrive pas à intégrer le critère correctement ? Quelqu'un peut il m'aider ?

2 réponses

Messages postés
2476
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
22 octobre 2020
1 274
Bonjour,

Un Somme si peut très probablement être trouvé mais voici une formule qui fonctionne pour le mois:

=SOMMEPROD((MOIS(A1:A4)=1)*B1:B4)

Pour rajouter l'année au cas ou :
=SOMMEPROD((MOIS(A1:A4)=1)*B1:B4*(ANNEE(C1:C4)=2014))

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Merci diablo, ça fonctionne effectivement.

J'avais trouvé entre temps avec somme.si.ens :

=SOMME.SI.ENS(A1:A10;B1:B10;">=01/01/2014";B1:B10;"<=31/01/2014")
pour janvier 2014 par exemple, et qui permet de bien personnaliser la plage de dates.

En espérant que ça serve.