Problèe de taille de pièces jointes limitées sur Contact form 7 [Fermé]

Signaler
Messages postés
71
Date d'inscription
vendredi 27 décembre 2013
Statut
Membre
Dernière intervention
18 janvier 2020
-
 be -
Bonjour,

Je me permets de vous exposer mon problème pour lequel je ne parviens pas à trouver de solution.
Je ne parviens pas à envoyer de fichier supérieur à 7Mo en pièce jointe sur mon formulaire.
Message d'erreur:
« Une erreur s’est produite lors de l’envoi de votre message. Veuillez essayer à nouveau plus tard. »

- J'ai fais le point avec mon hébergeur (OVH)= ok

- Boite mail testée = accepte + de 7 Mo en mail direct.

- J’ai crée un répertoire pj-temp provisoire (mode 755) sous la racine et j’ai rajouté le chemin dans wp-config.php pour modifier le chemin de la variable WPCF7_UPLOADS_TMP_DIR

- J'ai remplacé mon adresse mail de destination par mon adresse Gmail: même message d’erreur.

- Création d'un fichier php.ini avec le code suivant:
upload_max_filesize = 64M puis testé avec 10 Mo
post_max_size = 64M puis testé avec 10 Mo
max_execution_time = 300

- Modification du .htaccess:
php_value upload_max_filesize 64M
php_value post_max_size 64M
php_value max_execution_time 300
php_value max_input_time 300
Génère un message d'erreur qui plante le site.

- Caches vidés = KO

- Testé sur Firefox puis Chrome = KO

- J’ai effectué une recherche texte avec les critères suivants dans tous les répertoires.
En regardant le contenu des fichiers trouvés, je n’ai pas trouvé de limite (suis-je passé à côté d’une info…?)
Increase Max Upload Filesize
upload_max_filesize

- J’ai trouvé un fichier wp-content/uploads/wpcf7_uploads/.htacess auquel j’ai rajouté sans succès:
php_value upload_max_filesize 64M
php_value post_max_size 64M
php_value max_execution_time 300
php_value max_input_time 300

Voilà :)
Ca vous parle ce genre de problème?

Cordialement


Ma configuration WP actuelle :

– Version de WordPress : 4.7.5
– Version de PHP/MySQL : 7.0.15 / 5.6.34
– Thème utilisé : Twenty Twelve Child
– Thème URI : https://wordpress.org/themes/twentytwelvechild/
– Extensions en place : Ad Inserter (2.1.5), Akismet Anti-Spam (3.3.2), Contact Form 7 (4.7), Contact Form 7 Conditional Fields (1.3.2), Custom Background Changer (2.0), Custom Post Type UI (1.5.3), Disable Comments (1.6), Duplicate Post (3.2), Enhanced Media Library (2.4.4), Forum_wordpress_fr (4.1), Jetpack by WordPress.com (4.9), List Custom Taxonomy Widget (4.1), Members (1.1.3), Meta Slider (3.5.1), Multifile Upload Field for Contact Form 7 (1.0.1), OpenHook (4.2.1), Page Builder by SiteOrigin (2.5.2), PHP Code Widget (2.3), Really Simple CAPTCHA (1.9), Recent Posts Widget With Thumbnails (5.0), Relevanssi (3.5.8), Search & Filter (1.2.9), Search & Filter Pro (2.3.3), SiteOrigin Widgets Bundle (1.8.5), WP Responsive Menu (2.0.7)
- Adresse du site : http://prestidom.fr
- Nom de l’hébergeur : Apache

1 réponse

Bonjour à tous,

Je reviens vers vous car les tests ayant évolués, je souhaiterais votre avis sur un point.

J'ai installé "Caldera Form" sur mon W.Press.
L'envoi de mail supérieur à 7/8 Mo est toujours en échec comme c'est le cas avec "Contact Form 7".
OVH me dit que cela provient du fait que je dois subir une limitation de type: Temps exécution, Utilisation CPU, Taille maximal d'un post etc...
Que cela est lié à mon hébergement mutualisé et m'invite à changer de formule....

J'avoue être étonné qu'on ne puisse pas envoyer une pièce jointe de 8Mo chez OVH sur un serveur mutualisé...
D'autre part je constate que, sur "Caldera Form", il y a la possibilité de faire en sorte que la pièce jointe soit transmise directement dans les "Média" de W.Press.
Et là, comme par hasard, ça fonctionne parfaitement...
Je reçois dans les médias en quelques secondes un fichier de 16 Mo...

Qu'en pensez-vous?