Formule identique selon critères [Résolu/Fermé]

Signaler
-
Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
-
Bonjour,

Je souhaite avoir une formule identique pour mon tableau afin d'afficher "oui" quand il retrouve le résultat dans un tableau de données.

J'ai réussi à trouver une formule mais elle est différente selon les critères, je souhaiterai 1 formule pour la tirer vers le bas.

En jaune sur ce fichier : http://www.cjoint.com/c/GCpjWM2ACCW

Merci d'avance

2 réponses

Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
5 563
Bonjour
essayez avec:

=SI(NB.SI(A:D;G3);"oui";"")

crdlmnt

Bonjour,

Cela fonctionne mais ça recherche dans les données du tableau alors que je souhaite que ça cherche en fonction de la colonne correspondante.

Exemple : si je met un NOM (A) dans la colonne VILLE (C) il affiche "oui" alors qu'il n'est pas dans la bonne colonne.

Le but étant de chercher dans les colonnes correspondantes.
Messages postés
2818
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
28 octobre 2020
386
Bonjour,

Pas compris l'exemple ....

Un essai, avec une matricielle

https://www.cjoint.com/c/GCpkGXsWJzy

Crdmt
Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
5 563
vi, une virgule de trop, je pense:
=SI(NB.SI(DECALER($A$1;;EQUIV(F3;$A$1:$C$1;0)-1);;100);G3):"oui";"")
crdlmnt
Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
5 563 > Dav75
Décidément, on va y arriver....:-((
suis mal réveillé
=SI(NB.SI(DECALER($A$1;;EQUIV(F3;$A$1:$C$1;0)-1;;100);G3);"oui";"")

les deux points après ;G3) sont devenus point virgule!!!

avec mes excuses, celle là , vérifiée, Excel l'accepte.. mais je ne sais plus si elle va faire ce que vous attendez!

crdlmnt
J'ai déplacé 100 dans la hauteur et c'est good !

Thx !
Messages postés
25456
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
5 563
Ben ouf,
je passe le sujet en résolu
Bonne route
crdlmnt