Recherche 2 crireres dans 2 tableaux...

Résolu/Fermé
Signaler
-
Messages postés
6
Date d'inscription
samedi 23 août 2014
Statut
Membre
Dernière intervention
8 mars 2017
-
Bonjour,

Je viens chercher de l'aide pour résoudre mon casse tête...

J'ai sur une feuille excel, qui sert de chrono facture un tableau avec plusieurs colonnes (date, n° chrono, fournisseur, montant, signataire, affaire)

Sur une autre feuille , j'ai un tableau avec 2 colonnes : fournisseur, affaire

Je souhaite que lorsqu'une facture du tableau 1 a le même fournisseur ET la même affaire que la liste tableau 2, cela me l'indique.

Je ne sais pas si cela est bien clair...

Je vous remercie par avance pour votre aide

5 réponses

Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
98
Salut,

dans la feuille 2, j'ai ajouté une colonne avec cette formule :
=NB.SI.ENS(Feuil1!C:C;Feuil2!A2;Feuil1!F:F;Feuil2!B2) 


Avec :
Feuil1 : contient date, n° chrono..
Feuil2 : contient fournisseur et affaire

Feuil1 colonne C = fournisseur
Feuil1 colonne F = affaire
Feuil2 colonne A =fournisseur
Feuil2 colonne B = affaire

Ma formule te renvoie 0 s'il n'y a pas de correspondance, 1 s'il y a une correspondance.


--
Messages postés
26317
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
6 134
Bonjour

sans modèle, faudra adapter (et pour un Excel >= 2007)
en tableau 1 (feuil1)

fournisseur en C, affaire en F (feuil2)
en tableau 2 fournisseur en A affaire en B

en feuil2 C2 la formule:

=SI(NB.SI.ENS(feuil1!C:C;A2;feuil1!F:F;B2);"existe";"")

crdlmnt



Messages postés
6
Date d'inscription
samedi 23 août 2014
Statut
Membre
Dernière intervention
8 mars 2017

Bonjour,

Je vous remercie pour vos réponses mais ce n'est pas ce que je recherche...
Je vais tenter de mieux m'exprimer et d'illustrer.

Je reçois tous les jour des factures listées dans un fichier "chrono" que je transmets ensuite a diverses personnes pour validation (feuille 1 sur mon fichier)

Certains fournisseurs sont des "sous traitants" et ont un circuit de validation différent (feuille 2 sur mon fichier). Je souhaite pouvoir identifier ces factures plus facilement, c'est a dire que lorsque je saisie sur ma feuille 1 une facture d'un fournisseur listé en feuille 2 sur un chantier correspondant, que quelque chose me l'indique sur ma feuille 1.

Dans mon exemple ci-joint, j'aimerais qu'il se passe quelque chose sur la ligne 62

J’espère que c'est plus clair...

Merci par avance pour votre aide

Messages postés
26317
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
6 134
non, ce n'est toujours pas clair...
doit on comprendre que si on trouve dans le tableau du haut, une ligne qui contient à la fois le nom du fournisseur C et le N° de chantier en H, il faut qu'il se passe "quelque chose" dans la ligne
comme par exemple ligne 62 avec access dallage et 10045??

Si c'est ça, quel est ce "quelque chose"??? et où? et dans quelle feuille

Parce que ma formule placé en C du tableau en bas vous renverra existe en ligne 9

Si ce n'est pas ça, ré-expliquez!
à vous lire

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
6
Date d'inscription
samedi 23 août 2014
Statut
Membre
Dernière intervention
8 mars 2017

C'est exactement ca pour le principe.
Pour le "quelque chose" ce serait par exemple une X dans le 1er tableau en I62.
C'est a dire je pense, une formule a chaque ligne de la colonne I dans le chrono qui réponde toujours "0" sauf si les critères du tableau 2 sont trouvés.
Messages postés
26317
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
6 134
Re

alors il suffit de faire le contraire
tableau 1 (image du haut) en feuil1!
tableau 2 (image du bas) en feuil2!

en I16 feuil1:

=SI(NB.SI.ENS(feuil2!$A$2:$A$10;C16;feuil2!$B$2:$B$10;H16);"X";"")

à tirer sur la hauteur

crdlmnt
Messages postés
6
Date d'inscription
samedi 23 août 2014
Statut
Membre
Dernière intervention
8 mars 2017

Ça marche!!!

Super!
Merci pour le temps que vous m'avez accordé.

Bonne journée