Insérer une variable dans un lien à un autre fichier

Résolu/Fermé
damien2103
Messages postés
44
Date d'inscription
mercredi 22 août 2007
Statut
Membre
Dernière intervention
17 mai 2018
- Modifié par damien2103 le 23/02/2017 à 14:48
damien2103
Messages postés
44
Date d'inscription
mercredi 22 août 2007
Statut
Membre
Dernière intervention
17 mai 2018
- 24 févr. 2017 à 13:53
Bonjour,

je cherche une formule équivalente à celle ci-dessous mais en supprimant les " " autour de !B11 afin de pouvoir "tirer" la formule sur les cellules adjacentes et que mon B11 devienne B12, B13, B14, B15... et C11, D11, E11 etc

=INDIRECT("'[TABLEAU SUIVI CONTINU.xls]"&A1&"'!B11")

Est-ce possible ?

pour info mon exemple est issue d'une question déjà traitée https://forums.commentcamarche.net/forum/affich-4674076-nom-onglet-pour-formule-dans-feuille-excel

4 réponses

Raymond PENTIER
Messages postés
56115
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 mai 2022
17 203
24 févr. 2017 à 13:31
Bonjour.

Je te suggère une autre approche, avec Définir un nom :
feuil1 pour la plage A1:E15 de ta Feuil1
feuil2 pour la plage A1:E15 de ta Feuil2
feuil3 pour la plage A1:E15 de ta Feuil3
Dans la feuille "Onglet dupliqué" mettre en A2 la formule
=SIERREUR(INDIRECT($D$1);"-")
à recopier jusqu'en E17.
https://www.cjoint.com/c/GBymEM4maz4
1
Raymond PENTIER
Messages postés
56115
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 mai 2022
17 203
Modifié par Raymond PENTIER le 23/02/2017 à 17:54
Bonjour.

Enlever les "" ne va pas résoudre le problème ...
Il serait utile d'envoyer ton propre fichier :
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
0
damien2103
Messages postés
44
Date d'inscription
mercredi 22 août 2007
Statut
Membre
Dernière intervention
17 mai 2018
23
24 févr. 2017 à 10:00
Bonjour Raymond, merci pour ton message. En effet enlever les guillemets n'est pas possible :(

Voici le fichier exemple avec les détails de ce que je souhaite faire à l'intérieur : https://www.cjoint.com/c/GByi7d0SDap
0
damien2103
Messages postés
44
Date d'inscription
mercredi 22 août 2007
Statut
Membre
Dernière intervention
17 mai 2018
23
24 févr. 2017 à 13:53
Merci pour cette suggestion, c'est une très bonne idée. Je n'utilise jamais les noms mais je devrais m'y mettre...

Entre temps j'ai trouvé une méthode nettement moins élégante mais toutefois efficace en utilisant la fonction "remplacer".
Pour chaque cellule, j'ai remplacé Feuil1! par INDIRECT("'"&$D$1&"'!
puis ai ajouté ") à la fin de chaque cellule avant de remettre le signe =, à nouveau à coup de fonction Remplacer.
Bourrin mais ça marche
0