Fonction NB.SI problème [Résolu/Fermé]

Signaler
-
 LéoTaba -
Bonjour,
j'aurais souhaité savoir aussi s'il était possible d'insérer dans une formule NB.SI comme critère un renvoie sur un autre onglet car je n'y arrive pas.
Concrètement :
=NB.SI('Bilan STEP'!S4:S36;">'Références!F10'")
ne fonctionne pas, je m'explique : le critère ">'Références!F10'" renvoie à une case ou il y a écrit 375. Si dans la formule NB.SI je met comme critère >375, j'obtiens par exemple 3, alors que si je laisse le critère">'Références!F10'", peut importe la valeur de cette case, la formule donnera toujours 0.
Merci pour votre aide

3 réponses

Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Bonjour

essayez avec:

=NB.SI('Bilan STEP'!S4:S36;INDIRECT("Références!F10'"))

ou encore

=NB.SI('BilanSTEP'!S4:S36;INDIRECT(ADRESSE(10;6;;;"Référence")))

crdlmnt
Merci Vaucluse (toujours présent sisi)
Heu, le pb c'est que dans ma formule y a le comparateur > : oi dois je l'insérer dans ta formule ?
=NB.SI('Bilan STEP'!S4:S36;INDIRECT("Références!F10'"))
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Vi j'avais pas percuté sur la fonction du > et en fait mal pigé le problème. En fait indirect est inutile

=NB.SI('Bilan STEP'!S4:S36;">"&Références!F10))

il faut lier le signe entre guillemets et l'adresse par le signe &

valable quand le séparateur champ /valeur est le point virgule et quand le signe n'est pas une égalité (auquel cas il n'y a besoin de rien) et que la valeur cherchée est une adresse de cellule.

(SOMME.SI, NB.SI ETC..)

crdlmnt
ok merci !
RESOLU !