Décaler une formule indirect

Résolu/Fermé
Signaler
Messages postés
5
Date d'inscription
mardi 23 août 2016
Statut
Membre
Dernière intervention
20 février 2017
-
Messages postés
26409
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 janvier 2022
-
Bonjour,

je me doute que j'ai une vieille question, mais ça fait plus de 2 heures que je tente de trouver.

C'est assez simple.
J'ai plusieurs formules qui réfère à un mot qui est cherché dans une autre feuille.

J'utilise "indirect" et ça marche très bien.

Ex: =NB.SI.ENS(Natation!$K$6:$K$10486;"oui";Natation!$H$6:$H$10486;INDIRECT("A20"))+NB.SI.ENS(Natation!$K$6:$K$10486;"";Natation!$H$6:$H$10486;INDIRECT("A20"))

J'ai une liste de 150 noms environ... indirect va de A20 à A150

Je me suis rendu compte à ma grande tristesse que lorsque je glisse la formule d'une ligne à l'autre, les numéros de ligne change.. je descends + 1 +1... MAIS INDIRECT ne change pas lui, c'est toujours la même référence... j'ai fait une fois la correction manuel... j'ai changé les chiffres 1 à 1... C'EST LONG

Je me doute qu'il y a un possibilité avec la fonction adresse de faire un +1 à indirect...

J'ai tout tenté mais ça ne marche pas...

MERCI!!!!

2 réponses

Messages postés
55432
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
17 230
Il faudrait qu'on voie ton fichier.
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (8192 Ko maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
0
Messages postés
5
Date d'inscription
mardi 23 août 2016
Statut
Membre
Dernière intervention
20 février 2017

Merci pour votre réponse, mais je n'aurais pas pu vous télécharger le fichier, car il contient beaucoup d'information confidentielle...
0
Messages postés
26409
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 janvier 2022
6 188
Bonjour
vous n'avez peut être pas tout tenté :-))
essayez dans le code indirect

=INDIRECT("A"&LIGNE(A20))

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Messages postés
5
Date d'inscription
mardi 23 août 2016
Statut
Membre
Dernière intervention
20 février 2017

Merci ça fonctionne très bien. Je me doutais que c'étais très simple, mais étrangement je ne maitrise pas le &
0
Messages postés
26409
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 janvier 2022
6 188 >
Messages postés
5
Date d'inscription
mardi 23 août 2016
Statut
Membre
Dernière intervention
20 février 2017

Bonjour
le & équivaut au code CONCATENER
soit "A"&LIGNE(20) qui peut aussi s'écrire
CONCATENER("A";LIGNE(A20))
Je passe le sujet en résolu
Bonne route
crdlmnt
0