Recherche V - 2 Critères (date et nom)

Résolu/Fermé
axellet Messages postés 66 Date d'inscription mercredi 30 septembre 2015 Statut Membre Dernière intervention 3 février 2019 - 20 janv. 2017 à 11:10
axellet Messages postés 66 Date d'inscription mercredi 30 septembre 2015 Statut Membre Dernière intervention 3 février 2019 - 20 janv. 2017 à 17:56
Hello à tous,

J'essaie sans succès de trouver la formule (sans vba) afin de récupérer le montant pour chaque personne en fonction d'une date et du nom. Quand les montants sont absents, il faudrait avoir "montant absent"

Les deux tableaux proviennent de sources différentes et j'ai besoin de vérifier en même temps que j'ai bien toutes les dates pour chaque personne.... sur chacun des tableaux....

Je vous joins mon fichier pour que cela soit plus clair.

Merci à tous d'avance pour votre aide et bonne journée à vous

https://www.cjoint.com/c/GAukkc8qBbk

3 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
Modifié par Vaucluse le 20/01/2017 à 11:49
Bonjour
la formule en tableau 2 C2, à tirer sur la hauteur

=SIERREUR(INDEX('Tableau 1'!$C$1:$C$200;EQUIV(A2&B2;'Tableau 1'!$A$1:$A$200&'Tableau 1'!$B$1:$B$200;0));"non trouvé")

Attention!
cette formule est matricielle est doit être entrée avec la touche enter en maintenant les touches crtrl et shift enfoncées.
Elle se retrouve automaiquement entre accolades dans la barre de formule
Cette formule est assez lourde, limitez bien les champs à la hauteur utile (ici lmigne 1 à ligne 200)
crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 janvier 2023 1 761
Modifié par Patrice33740 le 20/01/2017 à 12:10
Bonjour,

En C2 du tableau 2 :
=SI(SOMME.SI.ENS('Tableau 1'!C:C;'Tableau 1'!A:A;A2;'Tableau 1'!B:B;B2)=0;"montant absent";SOMME.SI.ENS('Tableau 1'!C:C;'Tableau 1'!A:A;A2;'Tableau 1'!B:B;B2)) 
à tirer vers le bas
Cordialement
Patrice
0
axellet Messages postés 66 Date d'inscription mercredi 30 septembre 2015 Statut Membre Dernière intervention 3 février 2019
20 janv. 2017 à 17:56
Mille mercis à vous :-) Ca fonctionne nickel :-)

Bon week-end à vous
0