Chercher / trouver en excel

Résolu/Fermé
Fredbuyse
Messages postés
2
Date d'inscription
vendredi 20 janvier 2017
Statut
Membre
Dernière intervention
20 janvier 2017
- 20 janv. 2017 à 07:19
Fredbuyse
Messages postés
2
Date d'inscription
vendredi 20 janvier 2017
Statut
Membre
Dernière intervention
20 janvier 2017
- 20 janv. 2017 à 09:33
Bonjour,

je cherche la / les formules qui me permettent de résoudre le probleme suivant :

j'ai 6 cellules sucessives sur une ligne.
je souhaite savoir si dans ces cellules certains mots apparaissent (champ complet) et si oui, le reproduire. je cherche à savoir si soit "maison"; "villa" ou "rangee" apparait dans la succession de lignes.

example
A B C D E F rep
role - maison travail - toit maison
role - sante job - villa villa
sante - job issue club rangee rangee

j'ai essayé la concatenation, puis la formule avec Si et trouver mais j'obtiens un retour #valeur

merci
Frédéric

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 252
Modifié par Vaucluse le 20/01/2017 à 08:53
Bonjour
pour des textes de A à F
=SI(NB.SI(A2:F2;"*maison*");"maison";SI(NB.SI(A2:F2;"*villa*");"villa";SI(NB.SI(A2:F2;"*rangee*");"rangee";"")))

fonctionne si les textes une des cellules de la ligne contient un des mots (mais seulement la 1° trouvée, si d'autres cellules contiennent d'autres mots cherchés)
crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Fredbuyse
Messages postés
2
Date d'inscription
vendredi 20 janvier 2017
Statut
Membre
Dernière intervention
20 janvier 2017

20 janv. 2017 à 09:33
merci "Vaucluse", vous êtes merveilleuse / merveilleux !
bonne journée
0