Formule somme de deux colonnes avec un critére [Résolu/Fermé]

Signaler
Messages postés
37
Date d'inscription
lundi 10 juin 2013
Statut
Membre
Dernière intervention
11 janvier 2017
-
Messages postés
37
Date d'inscription
lundi 10 juin 2013
Statut
Membre
Dernière intervention
11 janvier 2017
-
Bonjour,

Je me tourne vers vous, car j'ai passé des heures à chercher une solution à mon problème mais je ne trouve pas.
Je vous fais un tableau simple:

Colonne 1........................Colonne 2................................Colonne 3
A..................................2............................................2
B..................................1............................................1
A..................................3............................................3

J'aimerai une formule qui m’additionne la colonne 2 + la colonne 3 si la colonne 1 répond au critères A. Donc la réponse devrait être 10.
Merci de votre aide !

Jérémie

2 réponses

Messages postés
2476
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
22 octobre 2020
1 284
Bonjour,

Voici une formule pour vous.
=SOMMEPROD((A1:A10="A")*(B1:B10+C1:C10))

Avec votre colonne 1 En A, la 2 En B et la 3 en C.
A adapter suivant vos besoins
Messages postés
37
Date d'inscription
lundi 10 juin 2013
Statut
Membre
Dernière intervention
11 janvier 2017

Merci beaucoup de votre aide !
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bon jour
et salut diablo (bonne année)

tout à fait exact.

Pour info on peut directement écrire si les champs à sommer sont contigüs:

=SOMMEPROD((A1:A10="A")*(B1:C10))

crdflmnt

Messages postés
2476
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
22 octobre 2020
1 284
Salut Vaucluse.
Bonne année a toi aussi:)

En effet, j'y avais pas pensez sur le coup au colonne à coté:)
Au moins il peut quand même l'adapter même s'il y a 40 colonne entre les deux.
Messages postés
37
Date d'inscription
lundi 10 juin 2013
Statut
Membre
Dernière intervention
11 janvier 2017

Merci pour votre à tous les deux ;)