EXCEL - Pb avec formule + de 7 SI imbriqués

Résolu/Fermé
CEDRICP Messages postés 1 Date d'inscription lundi 20 août 2007 Statut Membre Dernière intervention 20 août 2007 - 20 août 2007 à 18:21
lermite222 Messages postés 8702 Date d'inscription dimanche 8 avril 2007 Statut Contributeur Dernière intervention 22 janvier 2020 - 1 mars 2009 à 01:48
Bonjour,
J'ai un problème de formule dans Excel, il s'agit d'utiliser + de 7 SI imbriquées, mais avec des ET...
Je m'explique :

Voici la formule dans A1:
=SI(I7=1;"0.69";SI(ET(I7>1;I7<5);"0.76");SI(ET(I7>4;I7<11);"0.82") ...

Si dans I7 =1, j'ai 0.69 dans A1
Si I7 est compris entre 2 et 4, j'ai 0.76 dans A1
Si I7 est compris entre 5 et 10, j'ai 0.82 dans A1

etc j'ai 14 conditions à intégrer en tout

Le souci c'est qu'à partir du 2è SI, j'ai une erreur comme quoi la condition comporte trop d'argument !

Avez-vous une idée ?? Merci d'avance !
A voir également:

4 réponses

justagirl86 Messages postés 7 Date d'inscription mercredi 16 mai 2007 Statut Membre Dernière intervention 20 août 2007 2
20 août 2007 à 19:08
Salut,

Je pense avoir trouvé
=SI(I7=1;0,69;SI(ET((I7>1);(I7<5));0,76;SI(ET((I7>4);(I7<11));0,82)))

@ +
2
g Messages postés 1262 Date d'inscription vendredi 23 avril 2004 Statut Membre Dernière intervention 15 mai 2017 573
28 févr. 2009 à 22:20
Bonsoir,

Si tu as trop de SI, tu peux procéder par nommination de la formule.
Exiplication sur http://gerard.g.pagesperso-orange.fr/logexl_05_a.htm#nom_formule

Bonne soirée.
0
Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 135
1 mars 2009 à 00:40
=SI(a1>a2;a1;SI(a1>a3;a1;SI(a2>a3;a2;a3)))
0
lermite222 Messages postés 8702 Date d'inscription dimanche 8 avril 2007 Statut Contributeur Dernière intervention 22 janvier 2020 1 190
1 mars 2009 à 01:03
Bonjour,
Une autre idée, et si beaucoups de lignes où mettre ta formule beaucoup moins lourd.
Le classeur exemple
A+
0
Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 135
1 mars 2009 à 01:12
Comment vas-tu ?

Tu as répondu à CEDRICP, le lundi 20 août 2007 à 18:21:56

Moi, j'ai accepté, contrairement à mes habitudes, de répondre à fdiwa, le samedi 28 février 2009 à 22:02:43, bien qu'il se soit immiscé dans la discussion d'un tiers, discussion, qui plus est, périmée !

Cordialement.
0
lermite222 Messages postés 8702 Date d'inscription dimanche 8 avril 2007 Statut Contributeur Dernière intervention 22 janvier 2020 1 190 > Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024
1 mars 2009 à 01:27
Salut Raymond,
Je vais bien :)
Mais qu'est à co ??? j'ai rien pigé ??
A+
0
Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 135 > lermite222 Messages postés 8702 Date d'inscription dimanche 8 avril 2007 Statut Contributeur Dernière intervention 22 janvier 2020
1 mars 2009 à 01:42
Cette discussion a été lancée par CEDRICP le 20 août 2007, et il a eu la solution moins d'une heure après.

Et ne voila-t-il pas que fdiwa utilise cette discussion, 18 mois après, pour poser sa propre question (post 2) à laquelle g et moi-même avons répondu de manière assez laconique.

Mais toi, tu as proposé un fichier qui répond à la question de 2007, pas à celle de février 2009 ... OK ?

Bye !
0
lermite222 Messages postés 8702 Date d'inscription dimanche 8 avril 2007 Statut Contributeur Dernière intervention 22 janvier 2020 1 190 > Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024
1 mars 2009 à 01:48
Beh j'avais pas regarder la date :-))
Tu dit qu'il à eu la solution... je ne le pense pas, il parlais de 14 conditions !
Et comme le topic était remonter j'y ai répondu !
A+
0