Problème avec l'encodage des caractères

Résolu/Fermé
Signaler
Messages postés
464
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
15 septembre 2020
-
 cstan -
Bonjour tous le monde !

Toujours des problèmes, tellement sans importances, qu'on les laisse trainer...

J'utilise Firefox, et l'encodage des caractères pour les pages webs est : Occidental (ISO - 8859 - 1).
Aucun problème ! Tout est correct.

J'utilise aussi Thunderbird, et là par contre, dans le menu Options, j'ai exactement choisi le même encodage pour le courrier entrant comme sortant, soit : Occidental (ISO - 8859 - 1). Un choix par défaut.

Il y a aussi deux propositions que j'ai cochées :

*Appliquer l'encodage par défaut à tous les messages entrants
*Utiliser l'encodage par défaut pour les réponses.


Et là, c'est le gros bordel ! De plus, toujours dans le menu Options, une autre proposition cochée aussi, mais qui n'a peut être rien à voir avec mon problème :

*Utiliser l'encodage MIME "quoted printable" pour les messages contenant des caractères 8 bits.

"Quelqu'un serait me dire, quel encodage utiliser de manière définitive pour Thunderbird ?"

Merci par avance de se pencher sur mon petit cas ;-)

Crazybabe

11 réponses

Bonjour,

J'avais le même problème et j'ai trouvé la solution :o)

"Ouvrez le fichier (ou page web) dans Firefox. Allez dans Affichage > Encodage des caractères > Détection automatique > Universel. Firefox se fie maintenant uniquement au contenu du document pour déterminer l'encodage de manière automatique et ne tient plus compte de l'header ou de méta éventuel.

Retourner dans Affichage > Encodage des caractères et regarder l'encodage que Firefox à détecté."

Voir le site suivant : http://blog.weekli.com/en-finir-avec-les-comprendre-lencodage-13

voila, ça fonction no 1 avec mon Firefox et je n'ai plus de problème d'affichage et d'encodage

Eric L
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
464
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
15 septembre 2020
165
Bon en attendant le prince savoir ;-), j'ai juste décoché les deux options :

*Appliquer l'encodage par défaut à tous les messages entrants
*Utiliser l'encodage par défaut pour les réponses.


Ce qui n'a pas l'air de changer grand chose...

Crazybabe
Messages postés
18345
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
30 novembre 2021
5 443
Parce que j'ai TB en anglais. C'est bien Occidental (ISO - 8859 - 1).
Messages postés
464
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
15 septembre 2020
165
Ok !

Je m'essaie !

Merci, je te donne des news !

Crazybabe
Messages postés
464
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
15 septembre 2020
165
Hola !

Le seul problème, c'est que sur les deux liste déroulante,

je n'ai absolument pas ce choix : WESTERN ISO - 8859 !

Je fais quoi ?

Par contre, pour le courrier entrant, j'ai la proposition : Défini par l'utilisateur ; ce qui ne doit, de toute façon pas arranger mon histoire !!

Ben écoute, merci pour ton aide, je suis assez étonnée de ne pas trouver ton encodage, mais que faire !!??

Merci à toi !

Crazybabe
Messages postés
464
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
15 septembre 2020
165
OK ;-) !

Ben, écoute alors, je ne touche à rien, vu que j'ai décoché les deux options, puis dès que ça colle bien, je viens confirmer ça ici !

Merci à toi !

Crazybabe !
Messages postés
464
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
15 septembre 2020
165
Ok, c'est à présent parfait !

Merci !

Crazybabe
Messages postés
464
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
15 septembre 2020
165
Merci beaucoup à toi Éric !

Effectivement mon problème n'était pas résolu ; et merci pour le lien afin que j'y comprenne un peu quelque chose. Je reviendrais affirmer si effectivement, de cette manière je n'ai plus aucun problème !

Merci beaucoup à toi !

Au plaisir.
salut,moi j'ai le meme probleme d'encodage ie:j'ai une interface graphique sous Jbuilder et une BDD dans office access lors de l'insertion des caractere arabe le resultat sera comme suit ????????????????????? illisible
merci de votre aide
Faire un clic droit sur les courriers entrant -> Propriétés -> Et changer le police (UTF-8) par ISO-8859-1

Et voilà y a plus les caractères noir après le redémarrage.
Messages postés
18345
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
30 novembre 2021
5 443
Hello
Je n'ai pas de problèmes avec WESTERN ISO - 8859 - 1 et les 2 options désactivées.