SOMME PROD 2 critères différents

[Fermé]
Signaler
-
Messages postés
26236
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
-
Bonjour,

Je souhaite faire une somme de critères, voici mon tableau

Colonne A : Preneurs - Choix possible : (A-B-C-D-E-F)
Colonne B : Coéquipier - Choix possible : (A-B-C-D-E-F)

Je voudrai avoir le total du nombre de fois que le coéquipier (A-B-C-D-E-F) est présent quand celui n'est pas preneurs aussi.

Bien à vous,

3 réponses

Messages postés
54871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
16 775
Travailler sur des formules, des recherches et des mises en forme sans avoir le fichier, ça n'a jamais été productif ...
Envoie ton fichier, qu'on puisse voir où est l'erreur !
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Messages postés
26236
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
6 090
Bonjour
on ne voit pas bien ce qui ne va pas dans la dermière proposition de Raymond Pentier
voyez ici:
https://www.cjoint.com/c/GAgf7tDmrLC
crrlmnt
Messages postés
17601
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 octobre 2021
4 783
Bonjour,

Si j'ai bien compris la demande

=SOMME((plage1="critère1")*(plage2="critère2")*1)

en clair la formule pour la plage A2:B20 donne
=SOMME((A2:A20="A")*(B2:B20="A")*1)

tu peux mettre les critères dans des cellules exemple en F1 et G1 ce qui donne
=SOMME((A2:A20=F1)*(B2:B20=G1)*1)

Attention formule matricielle à confirmer en cliquant en même temps sur les trois touches du clavier Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ces accolades {}

A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Merci beaucoup pour ta réponse rapide,

J'ai réalisé ton exemple et cela fonctionne, sauf que là, j'ai la somme quand les deux critères (Joueurs et Coéquipier sont identiques).

Moi je souhaite avoir la somme de la colonne B quand le joueurs de la colonne B n'est pas identique à la colonne A

(Lettre correspondant aux noms des joueurs)

Colonne A - Colonne B
A - A
C - B
A - C
A - A
B - A
C - C
A - B

Le A ressort deux fois quand il est seul et une fois quand il est pas seul
Le B ressort zéro fois quand il est seul et deux fois quand il est pas seul
Le C ressort une fois quand il est seul et une fois quand il est pas seul


Voici les deux résultats que je souhaite avoir dans deux colonnes séparé:
CAS 1 : Le joueurs est seul (Ce cas, j'ai réussi)
=SOMMEPROD((A1:A7="A")*(B1:B7="A"))
=2

CAS 2 : Le joueur est accompagné
Ce cas la, je galère.


J'espère être clair dans mon énoncé :/

Merci par avance en tout cas.
Messages postés
54871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
16 775 > Florntn
=SOMMEPROD((A1:A7="A")*(B1:B7
<>
"A"))
>
Messages postés
54871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021

Bonjour,

Merci pour votre réponse. Après essai, cela ne fonctionne toujours pas. J'ai compris la logique mais n'arrive pas à l'appliquer.