Problème de formule a deux critères sur tableau excel [Résolu/Fermé]

Signaler
Messages postés
1
Date d'inscription
mardi 20 décembre 2016
Statut
Membre
Dernière intervention
20 décembre 2016
-
 Utilisateur anonyme -
Bonjour,

J'ai un gros blocage avec un tableau Excel. J'espère que quelqu'un aura une réponse a mon problème. Je m'explique. J'ai une colonne "taille" et une colonne "prix" pour deux articles différents.
Si une personne me prend les deux articles, elle a une remise sur l'ensemble, par contre si elle ne m'en prend qu'un seul, elle paye le prit unitaire:
Nom - SWEET taille prix - POLO taille prix
Pierre - XL 46.90€ - L 26.90€
Paul - M 46.90€ - Pas de commande
Jacques - Pas de commande - XXL 26.90€
Mathieu - S 46.90€ - M 26.90€
Je voudrais sur l'ensemble de mon tableau que les lignes où apparaissent une taille pour sweet et une taille pour polo, le résultat cumulé est de 70€, et pour celles où il n'y qu'une seule commande, c'est le prix unitaire affiché qui s'indique. J'espère que tout le monde aura vue clair dans mon énoncé. Merci d'avance aux spécialistes.

2 réponses

Messages postés
52534
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 octobre 2020
14 400
Bonjour.

Non ! Très honnêtement, j'ai une vue très brouillée de ton énoncé ...
Du peu que j'ai compris, je n'entrevois que la formule
=SI(B2+D2>70;70; B2+D2)
https://www.cjoint.com/c/FLuajFDK7cp

Et il n'y a pas besoin de "spécialistes" pour ce type de question ...
C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Utilisateur anonyme
 
Bonjour Raymond,

Ta formule peut être simplifiée ainsi : =MIN(B2+D2;70) ; d'autre part,
je vais proposer à SebBugey01 une autre solution possible, où je ne
peux pas appliquer cette formule, car j'ai adopté une présentation
simplifiée toute différente.  ;)

Cordialement.  :)
 

Bonjour SebBugey01,

Je te propose ce Fichier Excel 2007.

Tu pourras voir que j'ai adopté une présentation très différente
de ton énoncé, mais je crois que ça te plaira bien mieux !

Remarques

a) Le prix est indépendant de la taille : SWEET : 46,90 € ; POLO : 26,90 €
    => inutile de le noter à chaque fois : fait 1× dans un tableau séparé ;
    avec ajout du prix pour l'ensemble : Les 2 : 70,00 €

b) Dans le tableau principal, il suffit d'entrer les noms et tailles pour
    SWEET et POLO, la dernière colonne contient le Prix total.

c) La formule est en E7, et tirée ensuite vers le bas jusqu'en E15 :
    =SI(ET(C7<>"";D7<>"");E$4;SI(C7<>"";E$2;SI(D7<>"";E$3;"")))

Dis-moi ce que tu en penses, et si ça te convient.
Tu peux me demander une adaptation si besoin.

Si ton problème est réglé, merci d'aller en haut de page
pour cliquer sur « Marquer comme résolu ».

Cordialement.  :)