Si Mini + Maxi est impair

Résolu/Fermé
zhopte Messages postés 64 Date d'inscription mercredi 25 juin 2014 Statut Membre Dernière intervention 17 août 2018 - Modifié par zhopte le 9/12/2016 à 17:13
zhopte Messages postés 64 Date d'inscription mercredi 25 juin 2014 Statut Membre Dernière intervention 17 août 2018 - 9 déc. 2016 à 17:19
Bonjour,
Je débute en programmation c++.
J'ai le corriger mais il me le décrit comme çà;
Si Mini + Maxi est impair alors Y ← Y + (0 ou 1 aléatoirement)
comment je fais pour que Si Mini + Maxi est impair en c++.
Si non le reste j'arrive a me débrouiller.
Début
X ← Nombre aléatoire de 0 à 999.
N ← 0
Mini ← 0
Maxi ← 999
Faire
N ← N+1
Y ← (Mini + Maxi)/2
Si Mini + Maxi est impair alors
Y ← Y + (0 ou 1 aléatoirement)
Fin Si
Si Y > X alors
Maxi ← Y - 1
Afficher le message « Y Trop grand »
Sinon
Si Y < X alors
Mini ← Y + 1
Afficher le message «Y Trop petit »
Fin Si
Fin Si
Tant que Y ≠ X
Afficher le message « X … Gagné en N coups »
Retournez N
Fin
A voir également:

1 réponse

nagaD.scar Messages postés 4272 Date d'inscription samedi 8 septembre 2007 Statut Membre Dernière intervention 4 janvier 2023 251
Modifié par nagaD.scar le 9/12/2016 à 17:18
Salut,

Pour ca tourne toi sur le modulo:

si N modulo 2 = 1 , N est impair.
si N modulo 2 = 0 , N est pair

modulo en c++ : %

naga
zhopte Messages postés 64 Date d'inscription mercredi 25 juin 2014 Statut Membre Dernière intervention 17 août 2018
9 déc. 2016 à 17:19
merci
0