Extraire et regrouper des données de feuille différentes [Résolu/Fermé]

Signaler
-
Messages postés
25436
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
-
Bonjour,

Je suis novice sur Excel et je dois aujourd'hui regrouper des données de différentes feuilles.
Je m'explique :
J'ai trois feuilles de calcule
1ere feuille :
- colonne A le numéro de la pièce dans le logiciel entreprise
- colonne B la dénomination de la pièce
- colonne C le numéro de série de la pièce

2ème feuille :
- colonne A le numéro de la pièce dans le logiciel entreprise
- colonne B la dénomination de la pièce
- colonne C la date du contrôle d'entrée de la pièce

3ème feuille :
- colonne A le numéro de la pièce dans le logiciel entreprise
- colonne B la dénomination de la pièce
- colonne C la date du contrôle de sortie de la pièce

le but étant de connaître le temps écoulé pour chaque pièce entre le contrôle d'entrée et le contrôle de sortie en sachant que le lien entre chaque feuille est la colonne A

Je ne sais pas si j'ai été très clair ?
Merci d'avance.

1 réponse

Messages postés
25436
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
5 552
Bonjour*
si vous êtes novice, mieux vaut procèder en regroupant les données sur une feuille récapitulative comme suit, par exemple sur feuille 4

en ligne 1 à partir de A, les titres:
numéro_dénomination_date entrée_date sortie_temps
en ligen 2 en A2, à tirer sur la hauteur utile:
=Feuil1!A2 (de façon à avoir la liste des N°
en B2
=Feuil1!B2
en C2
=SIERREUR(RECHERCHEV($A2;Feuil2!$A:$C;3;0);"")
en D2
=SIERREUR(RECHERCHEV($A2;Feuil3!$A:$C;3;0);"")
en E2:
=D2-C2 pour avoir le nombre de jours entre deux dates

Respectez bien les signes $ aux bons endroits

il est possible en E de placer une formule qui ne compte ques jours ouvrables...

notez que le code SIERREUR(formule);'"") sert à éviter d'avoir un affaichage d'erreur (#N/A) si le code de feuil1! n'existe pas en feuil 2 ou 3

Restera à définir si des contrôles sont en cours auquel cas vous aurez une date en C et pas en D

dans ce cas, complèter en E la formule avec:

=SI(ET(C2>0;D2="");"en cours";D2-C2)

revenez si besoin

crdlmnt





Je teste ça merci beaucoup !
Messages postés
25436
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
5 552
OK mais attention, cette solution suppose que la pièce n'apparait qu'une fois dans la liste des feuil2 et 3, (un seul contrôle donc) car dans tous les cas, les formules de recherche ne vous renverrons que la 1°
si ce n'est pas le cas, revenez, ce sera juste un peu plus compliqué!
enfin... un gros peu! :-))
(je retire le résolu en attendant pour ne pas vous perdre!)
crdlmnt
Pas de panique la pièce ne passe qu'une fois au contrôle d'entrée et qu'une fois au contrôle de sortie et cela sans exception ! Merci :)
Messages postés
25436
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
5 552 > Liséea
Alors je remet le résolu :-)
bonne route
crdlmnt