Fonction SI imbriqué [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 7 décembre 2016
Statut
Membre
Dernière intervention
7 décembre 2016
-
Messages postés
4
Date d'inscription
mercredi 7 décembre 2016
Statut
Membre
Dernière intervention
7 décembre 2016
-
Bonjour,
J'essaye d'utiliser une fonction si :
=SI(AF4>$AF$2*2;2;SI(AF4>$AF$2;1;SI(AF4<$AF$2;0;SI(AF4>$AG$2;0;SI(AF4<$AG$2;-1;SI(AF4<$AG$2*2;-2))))))

AF2 = 0.1 et AG2=-0.1
Voila ce que je veux en français, si AF4 est supérieure à 0.2 alors 2, si AF4 est supérieur à 0.1 alors 1, si AF4 est entre 0.1 et -0.1 alors 0, si AF4 est inférieur à -0.1 alors -1 et si AF4 est inférieur à -0.2 alors -2.

Ma fonction ne fonctionne pas. Quelqu'un peut me dire comment faire ?

Merci !

3 réponses

Messages postés
2476
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
22 octobre 2020
1 275
Bonjour,

Voici une formule pour vous:
=SI(AF4<=-0.2;-2;si(AF4<=-0.1;-1;si(AF4<0.1;0;si(AF4<0.2;1;2))))

Normalement ca devrait fonctionner comme voulu, tenez nous au courant
Messages postés
4
Date d'inscription
mercredi 7 décembre 2016
Statut
Membre
Dernière intervention
7 décembre 2016

merci, ça marche parfaitement !
Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
83
Salut


=SI(AF4<2*$AG$2;-2;SI(AF4<$AG$2;-1;SI(AF4<$AF$2;0;SI(AF4<2*$AF$2;1;2))))


--
Messages postés
4
Date d'inscription
mercredi 7 décembre 2016
Statut
Membre
Dernière intervention
7 décembre 2016

merci, j'ai utiliséla formule de diablo13800
Messages postés
818
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
28 octobre 2019
60
Bonjour ,

=SI(AF4 > $AF$2*2; 2;Si( AF4 > $AF$2 ; 1; Si(AF4 > $AG$2 ; 0 ; Si(AF4 > $AG$2 *2 ; -1 ; -2))))

Les bornes supérieur ne sont pas necessaires puisqu'elles sont déjà controlé dans la condition précédente.

Cordialement,
Messages postés
4
Date d'inscription
mercredi 7 décembre 2016
Statut
Membre
Dernière intervention
7 décembre 2016

merci, j'ai utilisé la formule de diablo13800