Trouver un nom dans une plage ou une ligne [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
dimanche 4 décembre 2016
Statut
Membre
Dernière intervention
4 décembre 2016
-
Messages postés
5
Date d'inscription
dimanche 4 décembre 2016
Statut
Membre
Dernière intervention
4 décembre 2016
-
Bonjour,
Je recherche la formule qui puisse me donner un nom quelconque inscrit dans une ligne:
J'ai en colonne A1 A2 une date qui est croissante exemple 1 janv 2 janv ect. En B1 une colonne avec un nom ou en C1, un nom ou en D1un nom ,qui représente une réservation avec le nom de la personne. Donc si j'ai quelque chose en B1 j'ai forcement rien sur les autre colonne. je voudrais retrouver en bout de ligne sur une même colonne tout les noms pour ainsi les renvoyer vers mon facturier. Pour résumer c'est un planning avec des réservations et les colonnes sont des chambres différentes mais comme c'est une suite familiale la chambre est différente si il y une, deux, trois ou quatre personnes donc si c 'est 3 pers le nom sera dans la colonne D. A étant la date B: 1 pers C: 2 pers D: 3 pers Ai je été assez clair merci de vos réponses

3 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
494
Bonjour,

Essaie avec :
=INDEX(B1:D1;;EQUIV("*";B1:D1;0))

A+
Messages postés
5
Date d'inscription
dimanche 4 décembre 2016
Statut
Membre
Dernière intervention
4 décembre 2016

Merci pour la réponse j ai mis la formule mais réponse: =#N/A
@+
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
494 >
Messages postés
5
Date d'inscription
dimanche 4 décembre 2016
Statut
Membre
Dernière intervention
4 décembre 2016

Pour permettre de comprendre, il faut joindre un fichier.
Pour cela :
1)	Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; clic droit dessus et "Copier l’adresse du lien"
5) Tu reviens dans ta discussion sur commencamarche , et dans ton message de réponse tu fais "Coller".

A+
Messages postés
5
Date d'inscription
dimanche 4 décembre 2016
Statut
Membre
Dernière intervention
4 décembre 2016
>
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016

https://www.cjoint.com/c/FLelwDMu4a4
Merci pour l'info le fichier est joint.
j'ai mis A B C D pour représenter les nom éventuels
Messages postés
23599
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2020
6 429
Bonjour,

comme tu ne peux avoir qu'un seul nom :
=B2&C2&D2
eric
Messages postés
5
Date d'inscription
dimanche 4 décembre 2016
Statut
Membre
Dernière intervention
4 décembre 2016

Aussi simple que ça merci çà fonctionne super.
Encore merci a tous
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
494
Si ton tableau ne correspond pas à ton énoncé, ça ne peut pas donner un bon résultat.

Le mieux serait que tu parviennes à comprendre la formule.

En P4, place la formule :
=SIERREUR(INDEX(H4:O4;;EQUIV("*";H4:O4;0));"")

=EQUIV("*";H4:O4;0) permet de trouver la position de la cellule renseignée dans la plage H4:O4.
Exemple : sur la ligne 4, la formule renvoie 1 puisque la cellule renseignée est la première de H4:O4).

=INDEX(H4:O4;;EQUIV("*";H4:O4;0)) permet de connaitre la valeur de la cellule renseignée dans la plage H4:O4.
Exemple : sur la ligne 4, la formule renvoie "A" puisque la valeur est celle de la première cellule de H4:O4).

=SIERREUR(INDEX(H4:O4;;EQUIV("*";H4:O4;0));"") permet de d'éviter l'affichage #N/A en cas d'erreur (si aucun nom n'est noté dans la plage H4:O4 par exemple).

A+
Messages postés
5
Date d'inscription
dimanche 4 décembre 2016
Statut
Membre
Dernière intervention
4 décembre 2016

merci pour tes réponse mais celle de Eric me suffit Cordialement.