Somme égal ou proche d'un nombre définie

Fermé
Messages postés
75
Date d'inscription
mardi 21 août 2012
Statut
Membre
Dernière intervention
24 décembre 2021
-
Messages postés
24291
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
-
Bonjour,

Afin d'améliorer un tableau et d'optimiser la pose de chauffage au sol, j'aimerais savoir s'il existe une formule ou macro pour retrouver des sommes automatiquement.
Par exemple dans ma colonne A le numéro de ma boucle. Dans ma colonne B la longueur de tube. Et en A1, B1 et C1mes différentes longueurs de couronne (100,120,200).


B2 : 85
B3 : 75
B4 :112
B5 : 93
B6 : 98
B7 : 43.

Afin d'avoir le moin de chute possible je dois trouver les sommes se raprochant de 200 :
Couronne 1 : 112+98 = 200
Couronne 2 : 93 + 85 = 178
Couronne 3 : 75 + 43 = 118

Ce qui me ferait pour optimiser les chutes : 2 couronnes de 200 et 1 couronne de 120 donc 22 ml de chute. Sur cette exemple c'est facile car j'ai peut de tube mais là j'ai un projet avec plus de 40 km du tube. Et encore plus dur il faut que je sache quelle adition il a fait, et bien sur il peut avoir une addition avec 3 ou 4 boucles.

Si vous avez une solution, merci d'avance.

1 réponse

Messages postés
24291
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
7 034
Bonjour,

Essai avec le solveur.
En G2:BN2 mettre les longueurs des couronnes dispos. Ici 20 de chaque.
-vider C5:Cx
-ouvrir le solveur, modifier les plages des contraintes en fonction du nombre de tubes (C5:Cx)
- cliquer sur Résoudre
Préparé pour 33 tubes et 60 couronnes. Tu peux étendre sur le même principe.
https://www.cjoint.com/c/FKipycps0nN
eric
Bonsoir,
Merci pour ta réponse mais je n'ai jamais utiliser le solveur. Je viens de l'installer mais quand je l'ouvre et que je clique sur résoudre il ne se passe rien.
Si tu pourrais m'expliquer plus en détail son utilisation.
Ma colonne C est vide. Les cellules c5 à c10 rempli. Donc ma cellule E2 est la somme de C5:C10.
Je vais dans outils =>solveur.
Clique sur résoudre et rien ne se passe.
Je dois forcement mal faire une code mais je ne sais pas quoi.
Messages postés
24291
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
7 034
Ne touche pas aux formules et C5:Cx vides. Laisse =SOMME(G4:BN4) dans E2