Problème avec clé principale/valeur nulle

Résolu/Fermé
meeks Messages postés 61 Date d'inscription mardi 19 juillet 2016 Statut Membre Dernière intervention 20 septembre 2017 - 14 oct. 2016 à 11:39
 Utilisateur anonyme - 21 oct. 2016 à 21:43
Bonjour,

Me revoici avec un nouveau problème concernant mon formulaire de commande...!

Voici mon problème, j'ai donc un formulaire F_commande avec un sous formulaire Ligne commande.
Si, après une erreur de saisie, je souhaite supprimer une ligne de commande dans le formulaire, j'ai ce message là qui s'affiche :


Si quelqu'un pouvait m'aider à pallier ce dysfonctionnement...

Merci beaucoup d'avance !!



A voir également:

7 réponses

Utilisateur anonyme
14 oct. 2016 à 21:55
re,

tu fais comment pour supprimer ?

A+
meeks Messages postés 61 Date d'inscription mardi 19 juillet 2016 Statut Membre Dernière intervention 20 septembre 2017 3
17 oct. 2016 à 10:11
Re,

Je vais sur le champ article et je supprime...

A+
Utilisateur anonyme
17 oct. 2016 à 19:42
Il faut que tu cliques sur le sélecteur (petit carré gris à gauche de l'article)...

A+
meeks Messages postés 61 Date d'inscription mardi 19 juillet 2016 Statut Membre Dernière intervention 20 septembre 2017 3
18 oct. 2016 à 09:27
Salut,

Merci mais ça me mets "impossible de supprimer ou modifier de modifier l'enregistrement car la table 'T_ProduitFournisseur' comprend des enregistrements connexes"...

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Utilisateur anonyme
18 oct. 2016 à 20:15
Salut,

regardes du côté des relations, et décoches "supprimer en cascade" sur la relation reliant l table t_produitfournisseur et la table detail_commande.

A+
meeks Messages postés 61 Date d'inscription mardi 19 juillet 2016 Statut Membre Dernière intervention 20 septembre 2017 3
19 oct. 2016 à 14:03
Salut,

Tu résous combien de problèmes par jour ?? Lol ou plutôt par nuit...

Ca me semble cohérent...suis pas au bureau, je teste ça demain et te dis.

Merci encore (combien de fois je t'ai déjà dis ça...)

A+
meeks Messages postés 61 Date d'inscription mardi 19 juillet 2016 Statut Membre Dernière intervention 20 septembre 2017 3
20 oct. 2016 à 09:47
Salut,

C'était pas coché...

A +
Utilisateur anonyme
21 oct. 2016 à 21:43
Résolu, en fait, il s'agissait d'un souci de recordset du sous-form, qui effaçait en cascade les enregistrements des tables liées...
0