Macro, somme sur une colonne variable [Fermé]

Signaler
-
 Bob -
Bonjour,

Après de nombreuses recherches, je ne parviens pas a adapter les différents code que j'ai pu trouver a ma problématique,

ajouter une somme variable en fonction du nombre de ligne ?
faire la somme de cellule B2 a la dernière ligne de la colonne B ou le résultat se trouve a la fin de la plage de données,

http://www.cjoint.com/c/FJkqTsvuV6g

Pouvez vous m'indiquer quel code utiliser ?
Merci

4 réponses

Messages postés
9703
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
2 avril 2021
2 080
Bonjour

Tu es sûr d'avaoir besoin d'une macro ?
formule en B16
=SOMME(DECALER($A$2;0;1;NBVAL(A:A)-2;1))
si tu insères une ligne avant la ligne total, elle sera prise en compte (dans la mesure où la colonne A est remplie)

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
9703
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
2 avril 2021
2 080
Va pour une macro
Dim lifin As Long, plage As Range
With Sheets("Feuil1")
lifin = Range("A" & Rows.Count).End(xlUp).Row
Set plage = Range("B2:B" & lifin)
Range("A" & lifin + 1).Value = "total"
Range("B" & lifin + 1).Value = Application.WorksheetFunction.Sum(plage)
End With

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Bonjour, merci pour ton retour.

Oui effectivement, la feuille est supprimée à chaque mise à jour.
La colonne A est mise à jour par macro à partir d'un fichier détaillé, cette formule que je souhaite automatiser avec le reste de la macro doit servir à synthétiser des informations.

Merci d'avance.
Bonjour,

merci,

cela fonctionne très bien