SOMMEPROD +2 conditions

Résolu/Fermé
felixloca Messages postés 5 Date d'inscription mardi 20 septembre 2016 Statut Membre Dernière intervention 21 septembre 2016 - 20 sept. 2016 à 14:23
felixloca Messages postés 5 Date d'inscription mardi 20 septembre 2016 Statut Membre Dernière intervention 21 septembre 2016 - 21 sept. 2016 à 14:22
Bonjour,

Pour des statistiques, je dois mettre au point une formule qui calcule le CA des clients par mois et dont la fiche client a été créée avant/après une certaine date. Pouvez-vous m'aider sur ce problème?
Merci d'avance!
A voir également:

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 319
20 sept. 2016 à 15:00
Bonjour
essayez avec
=SOMMEPROD((MOIS(D2:D100)=1)*(B2:B100<=DATEVAL("20/8/2016")*(C2:C100))


ajustez les adresses à vos besoins (les N° de lignes sont obligatoires avec ce code

crdlmnt
1
felixloca Messages postés 5 Date d'inscription mardi 20 septembre 2016 Statut Membre Dernière intervention 21 septembre 2016
20 sept. 2016 à 15:35
Bonjour Vaucluse,

Merci pour cette réponse rapide. Malheureusement, ça ne fonctionne pas, il y a parfois un changement de valeur mais pas cohérent (en tout cas avec le MOIS(....

Merci d'avance
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 319 > felixloca Messages postés 5 Date d'inscription mardi 20 septembre 2016 Statut Membre Dernière intervention 21 septembre 2016
20 sept. 2016 à 17:44
vous pouvez en dire plus? La formule fait le cumul de C pour toutes les dates de janvier avant le 20/8
ce n'est pas ce que vous voulez?
et pour aller plus loin, plutôt qu'une image, déposez votre modèle sur:
https://www.cjoint.com/
avec quelques explications et revenez ici coller le lien créé sur le site
à vous lire
0
felixloca Messages postés 5 Date d'inscription mardi 20 septembre 2016 Statut Membre Dernière intervention 21 septembre 2016
21 sept. 2016 à 08:54
Bonjour,

https://www.cjoint.com/c/FIvg0zKzQFy

J'ai appliqué la formule au premier mois =1 (janvier) et il me propose "90" comme réponse. C'est impossible car aucun des achats n'a eu lieu en janvier, ils ont tous lieu ne aout. Comment expliquez-vous ceci?
Merci
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 319
Modifié par Vaucluse le 21/09/2016 à 09:50
sans votre modèle, je ne peux pas l'expliquer... l'image ne suffit pas pour déterminer par exemple si vos date sont au bon format!
déposez un modèle Excel sur:
https://www.cjoint.com/
et revenez ici coller le lien donné par le site.
A vous lire
crdlmnt
0
felixloca Messages postés 5 Date d'inscription mardi 20 septembre 2016 Statut Membre Dernière intervention 21 septembre 2016 > Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022
21 sept. 2016 à 10:07
Bonjour Vaucluse,

Le lien est au dessus de mon message de 8h54: https://www.cjoint.com/c/FIvg0zKzQFy

Merci!
0