Fonction NB.SI renvoie valeur cellule! [Résolu/Fermé]

Signaler
-
 mongimo -
Bonjour,

J'utilise la fonction NB.SI et la fonction NB.SI.ENS, qui me renvoient le même problème.
Dans une colonne, j'ai des valeurs allant de 1 à 40. Je veux compter le nombre de cellules supérieures à 20 et inférieures à 20.
J'utilise : NB.SI(plage;">20"). Cette formule fonctionne et compte bien le nombre de valeurs de la colonne répondant à la condition.
Mais lorsque j'indique NB.SI(plage;"<20"), Excel me renvoie la première valeur de la colonne qui ne répond pas à la condition, c'est-à-dire 21.

Je suis sur Excel 2016 (Office Pro)

Merci de votre aide

4 réponses

Messages postés
2466
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
16 octobre 2020
1 262
Bonjour,

Etes-vous sur qu'il n'y a pas tout simplement 21 valeurs inférieur à 20 ? Car la première valeur pour laquelle la condition est fausse c'est 20 et non 21 ...

Après on peut pas vraiment se pencher sur votre problème sans avoir le tableau dont vous parlez.
allez sur :https://www.cjoint.com/ et mettez y votre tableau ( avec les données personnel caché ou omise, juste les valeurs nécessaire)
et copiez le lien que le site vous donnera a la suite de ce message
Messages postés
5522
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 octobre 2020
498
Bonjour

Je viens de faire un essai sur Excel 2010 les cellules sont remplies des nombre 1 à 40

cette formule

=NB.SI($A$1:$A$40;">20") résultat 20 de 21 à 40
celle-ci

=NB.SI($A$1:$A$40;"<20") résultat 19 de 1 à 19

le total des deux formules 39 logique
20 n'est pas plus grand, n'y plus petit que 20 mais égale à 20
Donc il n'y a pas de problème sur ce que j'ai compris de votre question
Messages postés
23574
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2020
6 409
Bonjour,

n'oublie pas qu'une cellule vide est comptée <20, il faut les soustraire de ton compte.
eric
Messages postés
5522
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 octobre 2020
498
Bonjour Eriiic

Je viens de regarder et si j'efface des données les cellules vides ne sont pas comptées
Messages postés
23574
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2020
6 409
mea culpa
Attendons son fichier alors.
Merci beaucoup de toutes vos réponses,

J'ai réussi à résoudre mon problème, il était lié à la réponse de Eriiic.

Je ne sais pas pourquoi Excel 2016 renvoie une valeur, et non un nombre de valeurs, mais j'ai trouvé une solution : il faut encadrer les valeurs.
J'ai dû rajouter une condition ">0", pour signifier que je cherche les valeurs comprises entre 0 et 20.
Ma formule est devenue : NB.SI.ENS(plage; "<20"; plage ; ">0").

Pour répondre aux autres réponses (merci de votre réactivité et de votre aide) :
@diablo13800 : J'ai un peu over-simplifié l'exposé de mon problème, mais j'avais bien la première valeur ne répondant pas à la condition, (c'est effectivement 20 la première ne vérifiant pas la condition > et non =>), j'avais vérifié en comptant manuellement le nombre de valeurs (je suis en fait sur une formule en NB.SI.ENS avec d'autres conditions, donc le nombre de valeurs correspondant à toutes les conditions était très inférieur à 21).

@PHILOU10120 : Je n'ai pas fait le test sur Excel 2010, je suppose que ça fonctionne mieux que sur 2016. Car j'ai refait un test avec une colonne toute simple, et ça me donne la même erreur.