Déploiement d'1 site PHP sur 1 réseau local

Résolu/Fermé
Messages postés
12
Date d'inscription
lundi 13 août 2007
Statut
Membre
Dernière intervention
22 novembre 2007
-
Messages postés
601
Date d'inscription
mardi 14 août 2007
Statut
Membre
Dernière intervention
19 janvier 2011
-
je débute en développement Apache/PHP5/Mysql
j'ai ecris un site web qui fonctionne en local en utilisant l'URL http://127.0.0.1/mon_site.html
je n'arrive pas à le déployer sur le réseau local de mon entreprise
en utilisant l'url http://mon_serveur_web/mon_site.html

j'obtiens la réponse : Impossible d'afficher la page
La page que vous recherchez est actuellement indisponible. Le site Web rencontre peut-être des difficultés techniques, ou vous devez modifier les paramètres de votre navigateur.

je ne sais pas si c'est au niveau de APACHE, ou de ma config réseau (activedirectory) que
je dois chercher.

Merci

2 réponses

Messages postés
601
Date d'inscription
mardi 14 août 2007
Statut
Membre
Dernière intervention
19 janvier 2011
144
A mon avi c'est ton apache qui est mal configuré. Il doit accepter les connexions sur localhost(127.0.0.1) mais doit pas être configuré pour accepter les requetes pointant sur l'ip de ta machine.
Pour voir ca edite le fichier de configuration d'apache (httpd.conf généralement) avec notepad par exemple et trouve une ligne du genre
Listen 127.0.0.1:80
et remplace par
Listen ip.de.ta.machine:80
Messages postés
12
Date d'inscription
lundi 13 août 2007
Statut
Membre
Dernière intervention
22 novembre 2007
1
merci beaucoup, ça marche
Messages postés
601
Date d'inscription
mardi 14 août 2007
Statut
Membre
Dernière intervention
19 janvier 2011
144
;)